Closed Bug 104332 Opened 23 years ago Closed 20 years ago

add enlarge/reduce font size option

Categories

(Other Applications :: ChatZilla, enhancement)

x86
All
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: guy_hutchison, Assigned: rginda)

Details

(Whiteboard: cz-patch)

Attachments

(1 file)

The default font on my system is frequently Arial/UnreadablySmall, so having
hotkeys for font zoom in/out in Mozilla is very nice.  I would like to have the
same feature in Chatzilla (View/Text Zoom menu).
try setting your DPI, under Prefs->Apperance->Fonts, that should fix your
default font size.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Chatzilla should use/honor browser zoom → add enlarge/reduce font size option
Blocks: patchmaker
No longer blocks: patchmaker
Status: NEW → ASSIGNED
Does DPI change the appearance of chatzilla fonts? It didn't seem so for me (v.
0.9.5).

Chatzilla was readable in 0.9.4, but pretty ugly in 0.9.5.
odd, that's what fixed it form me.  I had to set my display res to 96 DPI to get
my font's back to normal.  0.9.5.
Since this isn't all to hard to get started in, I've started looking at it. I'm
almost done making Text Zoom work, i jsut have to work out the name of the
element which is holding the "chat". 

robert, if you could advise on that, it might save me some time. :)

Thanks,

James
OS: Linux → All
You can cut and paste messages from the chat window into composer to see the
HTML.  The <xul:iframe> that holds the HTML is called "output-iframe".
The problem with changing DPI is that I have my browser fonts set up just how I
want them. Changing DPI will screw that up.
Eric, Actually, *correcting* your DPI will help web pages too.  The problem is
that chatzilla asks for a "10pt" font, but if your DPI settings are wrong, the
conversion from pt to px leaves you with something like a 9 or 8pt font.
No, because then to get the font sizes I want for web pages, I have to pick
something that doesn't scale well and looks like crap.

What I really want is to be able to set the base font size on Chatzilla to
something more like 12-16 points.
Remove myself from QA of 33 open Chatzilla bugs and change to default QA
contact, since I have no way to verify these easily.  Still no working Mozilla
on my primary platform and it doesn't look like it will happen anytime soon. :(
QA Contact: mozilla → samuel
This option is really needed.
Move unreadable small fonts too.
Especialy cyrilic..

Linux/KDE3.0/Mozilla1.2.1
CZ needs its own component for voting purposes. I have no votes available for
the browser to assign to CZ. :-( Unfortunately, I don't know JS either, or I
might try to fix this myself. :-(

On the now-standard Mozilla default 96 DPI for win/Mac (also common on Linux
@100DPI), 10pt is 13.3px, while the browser default is 16px.  That makes CZ .msg
text smaller than browser text by over 30% (13.3^2/16^2), and it's unchangable
except for those rare few willing to change DPI just for CZ, or
understand/create/adjust chatzilla.css.  Either the default CZ starting point
needs to be set to equal to the browser default (-moz-initial?), and/or the
means to change size easily needs to be implemented as a normal bug.

The absence of connection between CZ text size and browser default text size is
broken behavior, and should not be treated as enhancement.
Would it suffice (for now) to make Chatzilla use the browser's default font and
size?
The current Chatzilla (0.9.59) has a range of font options, including Make
Bigger and Make Smaller (completely with Ctrl-+ and Ctrl-- keys). I believe
these new options cover this bug, so resolving FIXED.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Ctrl-+ & Ctrl-- do only

[INFO]	Font size is Infinitypt in Chatzilla 0.9.59 [Mozilla/5.0 (OS/2; U; Warp
4.5; en-US; rv:1.7a) Gecko/20040201]
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Ok, this will be fun. The problem seems to be when using the DPI value of 0 in
Mozilla (which means "use system") it all falls apart. Will look into finding
out this DPI value a better way.
This changes the way the getDefaultFontSize gets the DPI so that it works even
when Mozilla is using the system DPI or some odd combination.
Attachment #140647 - Flags: review?(samuel)
Whiteboard: cz-patch
Attachment #140647 - Flags: review?(samuel) → review+
Comment on attachment 140647 [details] [diff] [review]
Calculate the "active" DPI the hacky way

Checked in. Bonsai and Tinderbox are playing up currently, so there's no sign
of the checkin on them, but Bonsai's CVS Log shows it.
Marking fixed as patch was checked in.
Status: REOPENED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: