password / logon dialog not shown

VERIFIED DUPLICATE of bug 62108

Status

()

Core
HTML: Parser
VERIFIED DUPLICATE of bug 62108
17 years ago
17 years ago

People

(Reporter: Bruce Robson, Assigned: harishd)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I have an HTML page on disk that includes an image loaded via HTTP from a server
that requires me to logon. If I load this HTML page without having previously
authenticated with the server during this browser session, then the password /
logon dialog is not shown and the image is not loaded. If I have previously
authenticated with the server then the image does load.

This occurs both when
a) the SRC= part of the IMG tag contains a relative URL and I have specified the
server using the HREF= part of the BASE tag
b) the complete URL is in the SRC= part of the IMG tag

I'm running Mozilla 0.9.4 under WINNT 4.0 SP6a
(Reporter)

Comment 1

17 years ago
added 4xp as this doesn't happen with Communicator 4.78
Keywords: 4xp
(Assignee)

Comment 2

17 years ago
Bruce: Could you please attach a testcase?
(Reporter)

Comment 3

17 years ago
Created attachment 53299 [details]
test case - only works within my company's Intranet
(Reporter)

Comment 4

17 years ago
To make a test case you need to know the URL of an image that needs
authentication before you can access it.

I'm sorry that the only ones I know are on my employer's Intranet and these are
not accessible from the Internet. Therefore I can't make a test case that is
suitable for you.

I have attached the simplified test case I made to demonstrate the problem
within our Intranet. If you know a suitable URL you can modify this by
1)  replacing the HREF= part of the BASE tag
2)  replacing the SRC= part of the IMG tag
This is a dupe of bug 62108 
(No Basic Authentication dialog for inline images <IMG>)
Please reopen if you disagree !


*** This bug has been marked as a duplicate of 62108 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.