[B2G][Camera] Camera capture button highlight animation is square.

RESOLVED FIXED in 2.1 S1 (1aug)

Status

Firefox OS
Gaia::Camera
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Marty, Assigned: wilsonpage)

Tracking

({regression})

unspecified
2.1 S1 (1aug)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.0 unaffected, b2g-v2.1 affected)

Details

(Whiteboard: [patch ready])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8461799 [details]
logcat-Camera.txt

Description:
After the first picture or video is taken, for every subsequent picture taken, the capture button will animate with a square icon when pressed, instead of the original circle.  This is most apparent when taking a video, and the highlighted button remains onscreen for the duration of the recording.


Repro Steps:
1) Update a Flame to 20140724040205
2) Open the Camera app
3) Press the capture button several times to take a picture.


Actual:
After the first picture, the capture button animation will be square.


Expected:
The capture button animation will always be a circle.

Environmental Variables:
Device: Flame Master
Build ID: 20140724040205
Gaia: c72257b2d27135bfcd68e89dd584182797784016
Gecko: 06ac51c2b8a8
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Keywords: Camera, Icon, Button, Circle, Square, Animation, Transition

Repro frequency: 100%
See attached: logcat, screenshot

-----------------------------------------------------------------------

This issue does NOT occur on Flame 2.0.
The icon animation is always a circle.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140724000201
Gaia: 29266e18c35f4e72e35f1bba0e34f2fb6b995cc3
Gecko: 178fe2efc41d
Version: 32.0 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Comment 1

3 years ago
Created attachment 8461800 [details]
Camera_Button_Screenshot.png
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Nominating for 2.1, is a regression from 2.0 to 2.1 and is highly visible.

Requesting a regression window.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression, regressionwindow-wanted
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
Build ID: 20140723085706
Gaia: 15c84c943e41ad834640a45e1e1c2ac804168af7
Gecko: dfc1543c9c50
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140723123306
Gaia: 5458f73e319759543fddf7e96d7ece4d78318e32
Gecko: 5b53be9551bb
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken gecko & last working gaia - issue does NOT repro
Gaia: 15c84c943e41ad834640a45e1e1c2ac804168af7
Gecko: 5b53be9551bb

First broken gaia &  last working gecko - issue DOES repro
Gaia: 5458f73e319759543fddf7e96d7ece4d78318e32
Gecko: dfc1543c9c50

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/15c84c943e41ad834640a45e1e1c2ac804168af7...5458f73e319759543fddf7e96d7ece4d78318e32

Caused by Bug 1038172 ?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
possibly broken by bug 1038172 ?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(wilsonpage)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(Assignee)

Updated

3 years ago
See Also: → bug 1045624
(Assignee)

Comment 5

3 years ago
Created attachment 8464012 [details] [review]
pull-request (master)
Attachment #8464012 - Flags: review?(dmarcos)
Flags: needinfo?(wilsonpage)
Attachment #8464012 - Flags: review?(dmarcos) → review+
(Assignee)

Comment 6

3 years ago
[Blocking Requested - why for this release]:

When bug 1038172 lands on 'v2.0' then this patch will need to be uplifted.
blocking-b2g: 2.1? → 2.0?
(Assignee)

Updated

3 years ago
Assignee: nobody → wilsonpage
(Assignee)

Comment 7

3 years ago
Landed on 'master'

https://github.com/mozilla-b2g/gaia/commit/88ede549ed4e6641e1c11d19f36d8549fdcbc712
Depends on: 1038172

Updated

3 years ago
blocking-b2g: 2.0? → 2.0+
Blocking to avoid regression on uplift.

Updated

3 years ago
Target Milestone: --- → 2.1 S1 (1aug)

Updated

3 years ago
Whiteboard: [patch ready]

Comment 9

3 years ago
Based on CAF call on 8/7, this is not a blocker for 2.0. It is a regression caused from patch in 1038172 and has landed on master. Marking it fixed and "-" from blocker.
Status: NEW → RESOLVED
blocking-b2g: 2.0+ → -
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.