If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[OMTC] BSOD while playing HTML5 video

RESOLVED WORKSFORME

Status

()

Core
Graphics: Layers
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Ziga Seilnacht, Assigned: bas)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140724030201

Steps to reproduce:

1. The problem is hardware specific, you need AMD graphic card with a specific driver version (13.352.1006.0), I see it on HP EliteBook 8770w with AMD FirePro M4000 graphic card.
2. Install the latest Windows Nightly (currently 34.0a1 (2014-07-24)).
3. Open http://www.youtube.com/watch?v=hxc4B1Jsix4 or any other YouTube video. Change video size and volume controls or just wait.


Actual results:

Windows crashed (blue screen), indicating that the problem is in the graphic driver (ati****something***.sys). I didn't catch the exact error code for the crash. I can reliably reproduce the crash.


Expected results:

The video should play without problems.

Setting the layers.offmainthreadcomposition.enabled preference to false prevents the crash. The crash also doesn't happen with the previous graphic driver version (13.251.1.0). I'm using AdBlock Plus and some simple UI add-ons, but I don't think those could be causing this problem. The details about the graphics are below. I can provide the minidump of the crash if it is of any help.

Graphics
Adapter Description:        AMD FirePro M4000 (FireGL V)
Adapter Drivers:            aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM:                1024
Device ID:                  0x682d
Direct2D Enabled:           true
DirectWrite Enabled:        true (6.2.9200.16571)
Driver Date:                4-15-2014
Driver Version:             13.352.1006.0
GPU #2 Active:              false
GPU Accelerated Windows:    1/1 Direct3D 11 (OMTC)
Subsys ID:                  176c103c
Vendor ID:                  0x1002
WebGL Renderer:             Google Inc. -- ANGLE (AMD FirePro M4000 (FireGL V) Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote:   true
AzureCanvasBackend:         direct2d
AzureContentBackend:        direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated:       0
:bas, :nical, if it doesn't need to block 1036457, please remove it.
Blocks: 1036457
(Assignee)

Comment 2

3 years ago
I believe the previous graphics driver version from AMD was blacklisted for Direct2D because of BSOD issues with fullscreen video, perhaps we should blacklist this one as well.
(Assignee)

Comment 3

3 years ago
Are people still regularly experiencing this BSOD? I'd hate to blacklist the latest AMD drivers as well, but if need be we'll have to do it.
(Reporter)

Comment 4

3 years ago
(In reply to Bas Schouten (:bas.schouten) from comment #3)
> Are people still regularly experiencing this BSOD? I'd hate to blacklist the
> latest AMD drivers as well, but if need be we'll have to do it.

Yes, I still see this BSOD as soon as I try to play videos on Youtube with the latest nightly.

Note that drivers version 13.352.1006, the ones that are crashing for me, are not the latest version of AMD's graphics drivers for desktop and notebook graphic cards, just for workstation graphic cards (and possibly only for HP mobile workstation graphic cards, the latest driver for AMD's discrete workstation cards is at version 13.352.1014, while the latest driver for Dell's mobile workstations is at version 13.352.1009).
(Assignee)

Comment 5

3 years ago
(In reply to Ziga Seilnacht from comment #4)
> (In reply to Bas Schouten (:bas.schouten) from comment #3)
> > Are people still regularly experiencing this BSOD? I'd hate to blacklist the
> > latest AMD drivers as well, but if need be we'll have to do it.
> 
> Yes, I still see this BSOD as soon as I try to play videos on Youtube with
> the latest nightly.
> 
> Note that drivers version 13.352.1006, the ones that are crashing for me,
> are not the latest version of AMD's graphics drivers for desktop and
> notebook graphic cards, just for workstation graphic cards (and possibly
> only for HP mobile workstation graphic cards, the latest driver for AMD's
> discrete workstation cards is at version 13.352.1014, while the latest
> driver for Dell's mobile workstations is at version 13.352.1009).

Any chance you know to what 'public' version numbers those numbers correspond? And do you have any idea how far back the problem goes on these devices? I sadly don't own an AMD workstation card.
(Reporter)

Comment 6

3 years ago
(In reply to Bas Schouten (:bas.schouten) from comment #5)
> Any chance you know to what 'public' version numbers those numbers
> correspond? And do you have any idea how far back the problem goes on these
> devices? I sadly don't own an AMD workstation card.

It looks like blocking this driver might not be needed after all, I checked with today's nightly and I cannot reproduce the BSOD anymore. Should I close this bug?

Regarding the driver versions, for my card (AMD FirePro M4000) the driver version on AMD's download page (I assume this is the 'public' version) matches the version reported by about:support (I assume this is the version you would use for blacklisting). I assumed that the other FirePro drivers are the same, I don't have other cards (I checked which driver version is available for download for different FirePro models on AMD's website).

I saw the problem only with the driver version 13.352.1006, the BSOD did not occur with driver version
13.251.1, which is the previously released public driver version for my card.
Bas, assigning to you since this seems to be a blacklist issue and I haven't had any experience with that. I am trying to make sure all remaining OMTC blockers are assigned, feel free to reassign it to me if you think I should be the one looking at it.
Assignee: nobody → bas
(Assignee)

Comment 8

3 years ago
(In reply to Ziga Seilnacht from comment #6)
> (In reply to Bas Schouten (:bas.schouten) from comment #5)
> > Any chance you know to what 'public' version numbers those numbers
> > correspond? And do you have any idea how far back the problem goes on these
> > devices? I sadly don't own an AMD workstation card.
> 
> It looks like blocking this driver might not be needed after all, I checked
> with today's nightly and I cannot reproduce the BSOD anymore. Should I close
> this bug?
> 
> Regarding the driver versions, for my card (AMD FirePro M4000) the driver
> version on AMD's download page (I assume this is the 'public' version)
> matches the version reported by about:support (I assume this is the version
> you would use for blacklisting). I assumed that the other FirePro drivers
> are the same, I don't have other cards (I checked which driver version is
> available for download for different FirePro models on AMD's website).
> 
> I saw the problem only with the driver version 13.352.1006, the BSOD did not
> occur with driver version
> 13.251.1, which is the previously released public driver version for my card.

Hrm, with public driver numbers I meant the things like 14.5, 14.6, etc. But if you can no longer reproduce.. maybe we should just close this? Tricky.
(Reporter)

Comment 9

3 years ago
(In reply to Bas Schouten (:bas.schouten) from comment #8)
> 
> Hrm, with public driver numbers I meant the things like 14.5, 14.6, etc. But
> if you can no longer reproduce.. maybe we should just close this? Tricky.

I tried to bisect this issue to see what might have fixed it, but now I can't reproduce the problem anymore, even with the builds that crashed for me originally. I've reinstalled the driver in the meantime, I suspect that is what fixed the issue for me.

Since it looks like the problem was caused by the corrupted driver on my machine I think that this can be closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.