Closed Bug 1043702 Opened 5 years ago Closed 5 years ago

[video] Video player timeline scrubber overlaps time when it reaches the end of the video

Categories

(Firefox OS Graveyard :: Gaia::Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1025147

People

(Reporter: amylee, Assigned: pivanov)

References

Details

(Whiteboard: [2.0-319MB-bug-bash] DUPEME)

Attachments

(1 file)

Build Information
Device: Flame
Gaia      8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/4bd4b0ae7bbe
BuildID   20140721000201
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

Description

Video player timeline scrubber overlaps time when it reaches the end of the 


Expected Results

Scrubber should not overlap timer

Steps to reproduce

1. Open video app
2. Play a video 
3. Fast forward to the ending. The scrubber overlaps the end time.
Whiteboard: [2.0-319MB-bug-bash] → [2.0-319MB-bug-bash] DUPEME
Blocks: 1069288
Assignee: nobody → pivanov
Hey Amy,
what we need to do here?

1. put the time over the scrub? (scrubber color and time text are white and maybe this option doesn't solve our problem)

2. we will apply new design for this part of Video App? (do we have spec for this one?)
Flags: needinfo?(amlee)
(In reply to Pavel Ivanov [:ivanovpavel] from comment #1)
> Hey Amy,
> what we need to do here?
> 
> 1. put the time over the scrub? (scrubber color and time text are white and
> maybe this option doesn't solve our problem)
> 
> 2. we will apply new design for this part of Video App? (do we have spec for
> this one?)

Hi Pavel, 

The scrubber should match the music player app controls in terms of the distance of the scrubber to the timer text so it doesn't overlap.

Let me know if you need a spec but basically the video player controls should be the same as the music controls.
Flags: needinfo?(amlee)
Attached file patch for Gaia/master
Attachment #8498842 - Flags: ui-review?(amlee)
Comment on attachment 8498842 [details] [review]
patch for Gaia/master

Looks perfect. Thanks for fixing this!
Attachment #8498842 - Flags: ui-review?(amlee) → ui-review+
Attachment #8498842 - Flags: review?(rnicoletti)
Comment on attachment 8498842 [details] [review]
patch for Gaia/master

Hi Pavel, thanks for the patch. I left a couple of comments in the PR. In any event, it turns out this bug is a duplicate of bug 1025147. That bug has been triaged and has been deemed 2.0 blocking. I was going to land the 1025147 patch (it is r+) but I think your patch is cleaner. Therefore, I will land yours to fix 1025147. Thanks again for the patch.
Attachment #8498842 - Flags: review?(rnicoletti) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1025147
You need to log in before you can comment on or make changes to this bug.