If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla determines content-type from file extension and not header

VERIFIED DUPLICATE of bug 46655

Status

()

Core
Networking: HTTP
VERIFIED DUPLICATE of bug 46655
16 years ago
15 years ago

People

(Reporter: Graham White, Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
URL produces a vCard object from an XML file. Mozilla treats this
as type XML, going by the file extension rather than the HTTP header
(which is correct).
worksforme with win2k build 20011011.
I get a download dialog with [text/x-vcard] and wget also reports 
mime-Type : [text/x-vcard]

Reporter: 
Which build are you using ? (Please include in all your bug reports the build ID)
(Reporter)

Comment 2

16 years ago
Mozilla build is 
Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.4) Gecko/20010913

Incidentally, it did the same in 0.9.1

Comment 3

16 years ago
Also seeing this with 2001101021/Redhat 7.1. URL brings up a download dialog
with [text/xml].
->Networking
Assignee: asa → neeti
Component: Browser-General → Networking: HTTP
QA Contact: doronr → tever

Updated

16 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
We don't determine the mime type from teh extention; we just display the
mimetype from the extention if we couldn't match.

*** This bug has been marked as a duplicate of 46655 ***

Comment 6

15 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh
You need to log in before you can comment on or make changes to this bug.