[NFC] Cannot share files often

RESOLVED DUPLICATE of bug 1043856

Status

Firefox OS
NFC
RESOLVED DUPLICATE of bug 1043856
4 years ago
4 years ago

People

(Reporter: Alison Shiue, Assigned: arno)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 affected, b2g-v2.1 affected)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Gaia      c72257b2d27135bfcd68e89dd584182797784016
Gecko     https://hg.mozilla.org/mozilla-central/rev/616e6924cb0b
BuildID   20140724160202
Version   34.0a1

STR:
Tap 2 phones to share an image

Expected result:
Share successfully

Actual result:
Files cannot be shared easily.
(Reporter)

Comment 1

4 years ago
Created attachment 8462452 [details]
sender_logcat.log
(Reporter)

Comment 2

4 years ago
Created attachment 8462453 [details]
receiver_logcat.log
(Reporter)

Comment 3

4 years ago
Created attachment 8462454 [details]
receiver_hcidump.log
(Reporter)

Comment 4

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
QA Whiteboard: [COM=NFC]
(Reporter)

Updated

4 years ago
Summary: [NFC] Cannot share files easily → [NFC] Cannot share files often
(Reporter)

Comment 5

4 years ago
[Blocking Requested - why for this release]: 

2.0 also has this issue. 

Gaia  	0a864988f5dce7f9f3dea9609e8ef054679c30ff
Gecko 	https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/2da96d621030
BuildID   20140727160207
Version   32.0
blocking-b2g: 2.1? → 2.0?
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
After discussing with Yoshi offline, this seems a duplicated of Bug 1043856.

Hi ashiue, can you help to double confirm after Bug 1043856 is fixed.
Flags: needinfo?(ashiue)
(Reporter)

Comment 7

4 years ago
Sure, I will try this issue again once Bug 1043856 has been fixed.
Flags: needinfo?(ashiue)
basic use case of a 2.0 feature, so blocking
blocking-b2g: 2.0? → 2.0+
Hi Arno, do you mind to take this? Or we can mark it as duplicated of bug 1043856.
Flags: needinfo?(arno)
(Reporter)

Comment 10

4 years ago
Created attachment 8470644 [details]
nfc_sender_20140811.log

Hi Arno, 

I try full flash 2.0 build
Gaia      de28796a8956a48bb98ca67df6a33e0622d642d1
Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/5256345f62bd
BuildID   20140810160202
Version   32.0

After I try transfer file almost 30 times (BT initial off), I encounter a problem that nfc would not turn off sender's BT after a fail transfer, and since then, the device always cannot transfer file successfully unless I reboot sender.
(Assignee)

Updated

4 years ago
Assignee: nobody → arno
Flags: needinfo?(arno)
(Assignee)

Comment 11

4 years ago
(In reply to ashiue from comment #10)
> After I try transfer file almost 30 times (BT initial off), I encounter a
> problem that nfc would not turn off sender's BT after a fail transfer, and
> since then, the device always cannot transfer file successfully unless I
> reboot sender.

Alison: I cannot replicate the problem. When sharing between two Flame devices whose BT is initially off, it is fairly easy to provoke a failed transfer by quickly removing the two devices. But in my tests the sender always correctly turns off BT. The logs you've uploaded don't show debug information from the NFC module so I can't see what is going on. Rebooting the device seems to indicate a deeper problem. Can you please tell me how you manage to provoke the error (quickly remove two devices or something else?). Also: when you come to the point where you have to reboot the sender, can you please try and share a file via BT sharing (without the NFC handover)? If this fails as well, it seems to indicate a problem with the BT layer.
Hi arno,
I think this is something relate to bluetooth. I will take the new bug.
(Reporter)

Comment 13

4 years ago
Thanks, Shawn. I file another bug (bug 1052304) for tracking this issue.

Marked this issue as duplicate of bug 1043856 since the latest 2.0 and 2.1 build no longer fail transfer file easily.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043856
(Reporter)

Updated

4 years ago
QA Whiteboard: [COM=NFC]
You need to log in before you can comment on or make changes to this bug.