Closed Bug 1043968 Opened 6 years ago Closed 6 years ago

crash in mozilla::WebrtcGmpVideoEncoder::Encode_g(webrtc::I420VideoFrame const*, webrtc::CodecSpecificInfo const*, std::vector<webrtc::VideoFrameType, std::allocator<webrtc::VideoFrameType> > const*)

Categories

(Core :: WebRTC, defect, critical)

x86
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1041232

People

(Reporter: adalucinet, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-5dfd8aad-4ab4-4649-bd51-9a4882140725.
=============================================================

STR:
1. Launch Firefox and wait for openH264 plugin to install
2. Navigate to http://mozilla.github.io/webrtc-landing/pc_test_h264.html
3. Click Play on the main pc1 video (as in http://goo.gl/qDrQCC)
4. Click Start and Share Selected Devices

Notes:
1. On Ubuntu I get a different signature: https://crash-stats.mozilla.com/report/index/74c1f0bc-2429-4bb7-ac43-0a1302140725. Should I log a different bug for this?
2. Unfortunately, on Mac OS X I cannot reproduce because of the crash bug 1042215.
3. Reproducible with latest Nightly (Build ID: 20140725030202)
Blocks: OpenH264
Bug 1041080 just made the plugin registration etc. work etc., it can't actually lead to the crashes here, hence not a blockee.
No longer blocks: 1041080
Looks like the two crash reports could be the same basic issue (just in encoder vs decoder possibly due to timing).
Media folks should be able to tell better when they look at this.
This should be fixed in the checkin for bug 1041232 which landed last night and hasn't merged to m-c yet.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041232
You need to log in before you can comment on or make changes to this bug.