[Regression] Error "aJID.trim is not a function" when deleting XMPP account

RESOLVED FIXED in 1.6

Status

Chat Core
XMPP
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: nhnt11, Assigned: clokep)

Tracking

({regression})

trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Timestamp: 26/07/14 12:19:34 am
Error: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "aJID.trim is not a function" {file: "resource:///modules/xmpp.jsm" line: 1001}]'[JavaScript Error: "aJID.trim is not a function" {file: "resource:///modules/xmpp.jsm" line: 1001}]' when calling method: [prplIAccount::remove]
Source File: resource://gre/components/imAccounts.js
Line: 621

This happens when I try to delete an XMPP account (both generic and GTalk, but not Facebook), regardless of whether the account is connected. The account does not get deleted, and I ended up with a duplicate of the GTalk account I tried to delete after my first attempt, though I cannot reproduce this. After restarting Instantbird the passwords for these accounts seemed to have been forgotten. I currently have no way to delete these accounts.
(Reporter)

Updated

4 years ago
Component: Account manager → XMPP
Product: Instantbird → Chat Core
(Assignee)

Comment 1

4 years ago
Created attachment 8462763 [details] [diff] [review]
Patch
Assignee: nobody → clokep
Status: NEW → ASSIGNED
Attachment #8462763 - Flags: review?(nhnt11)
(Assignee)

Updated

4 years ago
Blocks: 1018771
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 2

4 years ago
Comment on attachment 8462763 [details] [diff] [review]
Patch

Review of attachment 8462763 [details] [diff] [review]:
-----------------------------------------------------------------

This fixes the issue, thanks!
Attachment #8462763 - Flags: review?(nhnt11) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Comment 3

3 years ago
https://hg.mozilla.org/comm-central/rev/74fe45baef1e
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.6
You need to log in before you can comment on or make changes to this bug.