plaintext mail filter log files from nc4 torture mozilla (large text file slow to load)

RESOLVED DUPLICATE of bug 72885

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 72885
17 years ago
17 years ago

People

(Reporter: timeless, Assigned: Marc Attinasi)

Tracking

({perf})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
url is 6mb bz2 compressed file. steps: get file, bunzip2, output will be a 100mb
mailfilt.log file (generated over the course of a few years of nc4 mail filter
logging -- mostly of the file size is bugzilla and a few other active groups).

The file takes about 200mb of memory to load, which is really not bad, the
problem is that it takes a very long time to load.  In one of my mozilla builds
i saw lots of reflow spew to the console.
(Assignee)

Comment 1

17 years ago
Is there any difference between loading this 100mb file and any other 100mb
file? Yea, we suck on large text files - see bug 72885, which this is likely a
dup of.
(Assignee)

Updated

17 years ago
Summary: plaintext mail filter log files from nc4 torture mozilla → plaintext mail filter log files from nc4 torture mozilla (large text file slow to load)
This is slightly different in that this is text/plain instead of text/html, and
thus none of the additional factors like unclosed <font> or <p> come into the
picture.  Still, it's basically the same I'm sure.
Keywords: perf

*** This bug has been marked as a duplicate of 72885 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.