Can't record video - JavaScript Error: "TypeError: t is undefined" {file: "app://camera.gaiamobile.org/js/main.js" line: 1}

VERIFIED FIXED in Firefox OS v2.0

Status

--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: zcampbell, Assigned: dmarcos)

Tracking

({qablocker, regression, smoketest})

unspecified
2.1 S1 (1aug)
Other
Gonk (Firefox OS)
qablocker, regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [fromAutomation][xfail])

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
justindarc
: review+
Details | Review | Splinter Review
(Reporter)

Description

4 years ago
E/GeckoConsole( 4126): [JavaScript Error: "TypeError: t is undefined" {file: "app://camera.gaiamobile.org/js/main.js" line: 1}]

STR
1. Open camera app
2. Switch to video mode
3. Tap record 
4. Note logcat


Device: Flame
Gaia      dd42afb7d6d66a6c2bd999692fec6b6d553d23de
Gecko     https://hg.mozilla.org/integration/b2g-inbound/rev/7c5efe8157e0
BuildID   20140725123906
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
Last good build for our automation:

application_buildid: 20140725114232
application_changeset: 840c12c95eca
application_display_name: B2G
application_name: B2G
application_repository: https://hg.mozilla.org/integration/b2g-inbound
application_version: 34.0a1
build_changeset: 3aa6abd313f965a84aa86c6b213dc154e4875139
device_firmware_date: 1403855878
device_firmware_version_incremental: 110
device_firmware_version_release: 4.3
device_id: flame
gaia_changeset: 9c5b09649e937764c2a19177661c9afefa7c981c
gaia_date: 1406312425
platform_buildid: 20140725114232
platform_changeset: 840c12c95eca
platform_repository: https://hg.mozilla.org/integration/b2g-inbound



First bad build:

application_buildid: 20140725122309
application_changeset: c0cc85f3c4b9
application_display_name: B2G
application_name: B2G
application_repository: https://hg.mozilla.org/integration/b2g-inbound
application_version: 34.0a1
build_changeset: 3aa6abd313f965a84aa86c6b213dc154e4875139
device_firmware_date: 1403855878
device_firmware_version_incremental: 110
device_firmware_version_release: 4.3
device_id: flame
gaia_changeset: dd42afb7d6d66a6c2bd999692fec6b6d553d23de
gaia_date: 1406314961
platform_buildid: 20140725122309
platform_changeset: c0cc85f3c4b9
platform_repository: https://hg.mozilla.org/integration/b2g-inbound


looks like the only change is the Git build:

https://github.com/mozilla-b2g/gaia/compare/9c5b09649e937764c2a19177661c9afefa7c981c...dd42afb7d6d66a6c2bd999692fec6b6d553d23de
Keywords: regression
Whiteboard: [fromAutomation]
Whiteboard: [fromAutomation] → [fromAutomation][xfail]
[Blocking Requested - why for this release]:

Smoketest regression from 2.0+ patch.

bug 1041811 looks like it's the cause of this regression.

Diego - Can you provide a patch quickly or backout?
Blocks: 1041811
blocking-b2g: --- → 2.1?
Flags: needinfo?(dmarcos)

Updated

4 years ago
Keywords: smoketest

Updated

4 years ago
Keywords: qablocker
(Assignee)

Comment 3

4 years ago
Yes, I can provide a quick fix. Give me an hour.
Flags: needinfo?(dmarcos)
(Assignee)

Comment 4

4 years ago
Created attachment 8463440 [details] [review]
Pull Request

controllers/storage was missing one of the events from lib/storage triggered during configuration. controller/storage was binding the event listener after the configuration is run on lib/storage.
(Assignee)

Updated

4 years ago
Attachment #8463440 - Flags: review?(jdarcangelo)
Attachment #8463440 - Flags: review?(jdarcangelo) → review+
(Assignee)

Comment 5

4 years ago
I have a patch reviewed waiting for green on TBPL. This needs to be uplifted to 2.0 after bug 1041811.
Flags: needinfo?(jsmith)
[Blocking Requested - why for this release]:

(In reply to Diego Marcos [:dmarcos] from comment #5)
> I have a patch reviewed waiting for green on TBPL. This needs to be uplifted
> to 2.0 after bug 1041811.

Ok - bumping to 2.0? - when this lands, we'll want to notify the sheriffs to land bug 1041811 and this bug together.
blocking-b2g: 2.1? → 2.0?
Flags: needinfo?(jsmith)
(Assignee)

Comment 7

4 years ago
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/ab1de1ea5e0ac0e179c8af31a773c0314d29fa64
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Bug 1041811 is still set to [NO_UPLIFT]...
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #8)
> Bug 1041811 is still set to [NO_UPLIFT]...

Fixed. We'll want to uplift this bug & bug 1041811 together.
v2.0: https://github.com/mozilla-b2g/gaia/commit/506b04eb427c64dc242fa51dfbb1519872bebb63
Assignee: nobody → dmarcos
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.1 S1 (1aug)

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.