Closed Bug 1044422 Opened 8 years ago Closed 8 years ago

Can't scroll articles on yahoo.com

Categories

(Web Compatibility :: Mobile, defect, P2)

Other
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: hsteen, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-all] [css] [sitewait])

Steps to reproduce: 

1) Load www.yahoo.com
2) You will get a list of articles, click one
3) Try to scroll down

Bug: there is no way to scroll down.

The generated markup in Opera (Blink) when spoofing as a mobile includes this:

<div class="js-viewer-viewerwrapper" id="yui_3_12_0_1_1406376883314_832">

while the markup in Firefox spoofing as Fx OS has this tag with an extra class:

<div id="yui_3_12_0_1_1406376535833_817" class="js-viewer-viewerwrapper fx-slidein">

#Stencil .fx-slidein {
    position: fixed;
}

The fixed positioning prevents scrolling. Changing it to absolute or relative will fix the problem.
Bug 1014193 shows another scrolling issue on Yahoo
Whiteboard: [country-all] [css] [contactready]
Confirmed.
I have sent an email at our contact at Yahoo!.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [country-all] [css] [contactready] → [country-all] [css] [sitewait]
(In reply to Hallvord R. M. Steen from comment #1)
> Bug 1014193 shows another scrolling issue on Yahoo

> The fixed positioning prevents scrolling. Changing it to absolute or relative will fix the problem.

The problem is that the class that styles the element as fixed is *not removed* at the end of the animation (as it should.) This is why you don't see that class on Opera (Blink).
the problem is this experiecnes is only supposed to work on webkit browsers, as the
javascript only listens to Webkit specific events (WebkitAnimationEnd), and
hence it doesn't remove the class on animation end.

So either we fix that or configure traffic server to return normal frontpage experiences to
Firefox OS...
Hm looked at the code again, there is indeed a event listener for animationend. Will check that again and fix it
Bug id: #7059298 at Yahoo!

Thanks itiachang!
Actually, this issue could be related to this Firefox bug: https://bugzilla.mozilla.org/show_bug.cgi?id=625289

We ran into this when re-building my.yahoo and the behavior here seems identical.
The fix for this (bug #7059298 at Yahoo) should be pushed today.
Thanks a lot, Thierry. 
I just checked and indeed it has been fixed.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Great. Thanks Karl for reporting the issue to us.
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.