Sync authentication using FxAccount fails (Non-authentication error in _fetchTokenForUser: undefined)

RESOLVED DUPLICATE of bug 1071786

Status

()

P2
normal
RESOLVED DUPLICATE of bug 1071786
4 years ago
2 years ago

People

(Reporter: ts.bugzilla, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8463385 [details]
Sync error log - first occurance of the errors

Since updating Nightly past 20140723030202 Sync does not work anymore.
I have a collection of ~100 error log files in the \weave\logs folder.

Errors are e.g.

1406539728710	Sync.BrowserIDManager	ERROR	Non-authentication error in _fetchTokenForUser: undefined
1406539728710	Sync.Status	DEBUG	Status.login: success.login => error.login.reason.network
1406539728710	Sync.Status	DEBUG	Status.service: success.status_ok => error.login.failed

or

1406539791382	Sync.ErrorHandler	DEBUG	Flushing file log.
1406539791383	Sync.BrowserIDManager	ERROR	Background fetch for key bundle failed: No keyFetchToken
1406539791383	Sync.BrowserIDManager	ERROR	Could not authenticate: No keyFetchToken
1406539791383	Sync.SyncScheduler	DEBUG	Clearing sync triggers and the global score.
1406539791384	Sync.SyncScheduler	DEBUG	Next sync in 90000 ms.

Related to bug 1013064?
Bug 1013064 was backed out - does this work again for you now?

Do you have a master password set?
(Reporter)

Comment 2

4 years ago
I was using the 20140728 and 0729 nightlies, which should have the backout (bug 1013064 says "1 week ago"), but Sync did not recover.

I don't have a master password, which I said in Bug 1013064 comment 87, but strangely not here...

PS: Meanwhile I gave up and disconnected/logged-in again to get Sync working. I still have the log files, but they don't provide much detail...
(Reporter)

Comment 3

4 years ago
The same error happens on another machine after updating to 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140724030201 CSet: a91ec42d6a9c

First Weave error log:

1406919535888	Sync.Service	INFO	Loading Weave 1.36.0
1406919535889	Sync.Engine.Clients	DEBUG	Engine initialized
1406919535891	Sync.Engine.Clients	DEBUG	Resetting clients last sync time
1406919535899	Sync.Engine.Bookmarks	DEBUG	Engine initialized
1406919535903	Sync.Engine.Forms	DEBUG	Engine initialized
1406919535907	Sync.Engine.History	DEBUG	Engine initialized
1406919535911	Sync.Engine.Passwords	DEBUG	Engine initialized
1406919535914	Sync.Engine.Prefs	DEBUG	Engine initialized
1406919535918	Sync.Engine.Tabs	DEBUG	Engine initialized
1406919535918	Sync.Engine.Tabs	DEBUG	Resetting tabs last sync time
1406919535927	Sync.Engine.Addons	DEBUG	Engine initialized
1406919535928	Sync.Service	INFO	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0
1406919535935	Sync.SyncScheduler	DEBUG	Clearing sync triggers and the global score.
1406919535936	Sync.Status	DEBUG	Status.service: success.status_ok => success.status_ok
1406919535936	Sync.Service	DEBUG	Caching URLs under storage user base: https://sync-44-us-west-2.sync.services.mozilla.com/1.5/2255621/
1406919535936	Sync.Status	DEBUG	Status.service: success.status_ok => success.status_ok
1406919535937	Sync.Tracker.History	INFO	Adding Places observer.
1406919535942	Sync.Status	DEBUG	Status.service: success.status_ok => success.status_ok
1406919535943	Sync.Status	DEBUG	Status.service: success.status_ok => success.status_ok
1406919535945	Sync.Status	DEBUG	Status.service: success.status_ok => success.status_ok
1406919535947	Sync.Engine.AdblockPlus	DEBUG	Engine initialized
1406919535948	Sync.Status	DEBUG	Status.service: success.status_ok => success.status_ok
1406919535949	Sync.BrowserIDManager	ERROR	Non-authentication error in _fetchTokenForUser: undefined
1406919535950	Sync.Status	DEBUG	Status.login: success.login => error.login.reason.network
1406919535950	Sync.Status	DEBUG	Status.service: success.status_ok => error.login.failed
1406919535950	Sync.SyncScheduler	DEBUG	Clearing sync triggers and the global score.
1406919535951	Sync.SyncScheduler	DEBUG	Next sync in 600000 ms.
(Reporter)

Updated

4 years ago
Summary: Sync authentication using FxAccount fails → Sync authentication using FxAccount fails (Non-authentication error in _fetchTokenForUser: undefined)

Comment 4

4 years ago
Same problem on Windows.
I have confirmed nightly x86 and x86_64. Master password is not used.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140805030300 CSet: 7f81be7db528
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140805030300 CSet: 7f81be7db528

Neither Safe-mode nor disconnect/reconnect Fx account make Sync working... 

log in weaves/logs:

1407265087875	Sync.Service	INFO	Loading Weave 1.36.0
1407265087877	Sync.Engine.Clients	DEBUG	Engine initialized
1407265087878	Sync.Engine.Clients	DEBUG	Resetting clients last sync time
1407265087884	Sync.Engine.Bookmarks	DEBUG	Engine initialized
1407265087888	Sync.Engine.Forms	DEBUG	Engine initialized
1407265087892	Sync.Engine.History	DEBUG	Engine initialized
1407265087897	Sync.Engine.Passwords	DEBUG	Engine initialized
1407265087900	Sync.Engine.Prefs	DEBUG	Engine initialized
1407265087903	Sync.Engine.Tabs	DEBUG	Engine initialized
1407265087904	Sync.Engine.Tabs	DEBUG	Resetting tabs last sync time
1407265087910	Sync.Engine.Addons	DEBUG	Engine initialized
1407265087912	Sync.Service	INFO	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
1407265087915	Sync.SyncScheduler	DEBUG	Clearing sync triggers and the global score.
1407265087916	Sync.Status	DEBUG	Status.service: success.status_ok => success.status_ok
1407265087916	Sync.Service	DEBUG	Caching URLs under storage user base: https://sync-40-us-west-2.sync.services.mozilla.com/1.5/1822226/
1407265087917	Sync.Status	DEBUG	Status.service: success.status_ok => success.status_ok
1407265087917	Sync.AddonsReconciler	INFO	Registering as Add-on Manager listener.
1407265087917	Sync.AddonsReconciler	DEBUG	Adding change listener.
1407265087918	Sync.Tracker.History	INFO	Adding Places observer.
1407265087968	Sync.Status	DEBUG	Status.service: success.status_ok => success.status_ok
1407265087970	Sync.Engine.Greasemonkey	DEBUG	Engine initialized
1407265087971	Sync.Status	DEBUG	Status.service: success.status_ok => success.status_ok
1407265087973	Sync.BrowserIDManager	ERROR	Non-authentication error in _fetchTokenForUser: undefined
1407265087973	Sync.Status	DEBUG	Status.login: success.login => error.login.reason.network
1407265087973	Sync.Status	DEBUG	Status.service: success.status_ok => error.login.failed
1407265087973	Sync.SyncScheduler	DEBUG	Clearing sync triggers and the global score.
1407265087974	Sync.SyncScheduler	DEBUG	Next sync in 3600000 ms.

Browser Console:

1407265087973	Sync.BrowserIDManager	ERROR	Non-authentication error in _fetchTokenForUser: undefined Log.jsm:760
1407265087976	Sync.BrowserIDManager	ERROR	Background fetch for key bundle failed: No keyFetchToken Log.jsm:760
1407265087976	Sync.BrowserIDManager	ERROR	Could not authenticate: No keyFetchToken Log.jsm:760

Comment 5

4 years ago
Problem has been fixed in nightly 20140806, with fix of bug 1013064.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140806030201 CSet: 6cbdd4d523a7
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140806030201 CSet: 6cbdd4d523a7
(Reporter)

Comment 6

4 years ago
(In reply to Kosuke Kaizuka from comment #5)
> Problem has been fixed in nightly 20140806, with fix of bug 1013064.

What makes you assume that? The issue first occurred for me when that bug was initially in the tree before being backed out. So I would stay cautious and observe a bit...

Comment 7

4 years ago
ff34 fixed sync problem on osx for me, I just had to re-login

Comment 8

3 years ago
Thomas: can you still reproduce this?
Flags: needinfo?(ts.bugzilla)
Blocks: 1119667
Priority: -- → P2
(Reporter)

Comment 9

3 years ago
No, FxAccount works normally for me these days. The problems where in the conversion phase when it first landed, so I guess the code has proved itself in Release since then.
Flags: needinfo?(ts.bugzilla)
Given the no keyFetchToken symptom, I'm duping to 1071786.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1071786
You need to log in before you can comment on or make changes to this bug.