Closed Bug 1045151 Opened 8 years ago Closed 8 years ago

"Cancel" button on home screen not localized on 2.0

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

RESOLVED FIXED
2.1 S1 (1aug)
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: tchevalier, Assigned: kgrandon)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(4 files)

This is a regression from bug 1023714 , it's been fixed on 2.1 and uplifted on 2.0, but 2.0 is still affected (or regressed again).

STR:

Switch to French
Long press on home screen

Actual:
Cancel button appears in English

Expected:
Cancel button is localized
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.0?
Oops missed this one:
[Blocking Requested - why for this release]: Unlocalized string on the home screen for all locales
Working for me on: 

Gaia      8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/c6f9f0396153
BuildID   20140720160208
Version   32.0a2
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
B1TC20011210


Broken for me on:

Gaia      8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/4bd4b0ae7bbe
BuildID   20140721000201
Version   32.0a2
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
B1TC20011210


If I add regressionwindow-wanted will someone get this range lower for us? I'll also investigate in the meantime.
Oddly enough after rebooting the device I can no longer reproduce it. I saw this exactly once after an OTA update, but can't seem to repro.

Removing regressionwindow-wanted until we get a solid STR here.
Adding qawanted for verification of this bug and a STR. Please note: if you reproduce it, please see if it reproduces after a restart. Thanks!
Keywords: qawanted
Whiteboard: [systemsfe]
Issue DOES repro on today's 2.0, This bug occurs when changing the language through the FTU but does NOT repro when changing language through the settings menu. Issue DOES persist after a device reboot if the language was set during the FTU.

STR:
1. Flash device
2. During FTU Change the Language to other than English
3. Proceed to Homescreen
4. Long-press the Homescreen


Device: Flame 2.0
Build ID: 20140728104213
Gaia: 90a5a08192586f3e91852053e76fbb8321273f9d
Gecko: 9d7b4ff43468
Version: 32.0 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0



Leaving Regression-window call to Kevin G. to make - if he needs it after this info
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
blocking-b2g: 2.0? → 2.0+
Target Milestone: --- → 2.1 S1 (1aug)
Since we have a STR in comment 7, can we get a regression window here? Note that when I made comment 4 I was uncertain of the STR, so I'm not sure if it was accurate or not.
QA Contact: jmitchell
Mozilla-Aurora-Flame Regression Window:

Last Working:
Device: Flame 2.0
Build ID: 20140710065452
Gaia: 35a9b715e7348ec738ff6c8a59f50190390a06f2
Gecko: 9297a56e155e
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

First Broken:
Device: Flame 2.0
Build ID: 20140710075154
Gaia: d422c2f353816b0781fca219d13f7789205d589c
Gecko: 5399556b7238
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 35a9b715e7348ec738ff6c8a59f50190390a06f2
Gecko: 5399556b7238

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: d422c2f353816b0781fca219d13f7789205d589c
Gecko: 9297a56e155e

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/35a9b715e7348ec738ff6c8a59f50190390a06f2...d422c2f353816b0781fca219d13f7789205d589c
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
This appears to be broken by bug 1031890 ? Can you take a look Cristian ?
Flags: needinfo?(crdlc)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Attached file Pull request - master
Attached file Pull request - V2.0
Comment on attachment 8464397 [details] [review]
Pull request - master

Stas or Gandalf - could either of you guys review this small patch? Thanks!
Attachment #8464397 - Flags: review?(stas)
Attachment #8464397 - Flags: review?(gandalf)
Comment on attachment 8464397 [details] [review]
Pull request - master

That sounds wrong:

> this.localize();
> window.addEventListener('localized', this.localize.bind(this));
> + navigator.mozL10n.once(this.localize.bind(this));

mozL10n.once will execute as soon as mozL10n resources are ready. If the resources are ready, then it will execute twice. If they are not, then why the first line?

'localized' event is fired at the same time as when once is executed. If you want this.localize to be fired on every retranslation just do:

navigator.mozL10n.ready(this.localize.bind(this));


instead of those three lines.
This will cover .once and then each onlocalized.
Attachment #8464397 - Flags: review?(stas)
Attachment #8464397 - Flags: review?(gandalf)
Attachment #8464397 - Flags: review-
Comment on attachment 8464397 [details] [review]
Pull request - master

Thanks Gandalf! The new logic is much more simple, and works well. Could you take another look if you have time?
Attachment #8464397 - Flags: review- → review?(gandalf)
Flags: needinfo?(crdlc)
Comment on attachment 8464397 [details] [review]
Pull request - master

awesome!
Attachment #8464397 - Flags: review?(gandalf) → review+
(In reply to Zibi Braniecki [:gandalf] from comment #16)
> Comment on attachment 8464397 [details] [review]
> Pull request - master
> 
> awesome!

Thanks for the quick review.

Master: https://github.com/mozilla-b2g/gaia/commit/b67ddd7d40b52e65199478b8d6631c2c28fdf41d
v2.0: https://github.com/mozilla-b2g/gaia/commit/3e868e8fa3431f66534fc0f90c41dc6bf3e2c33b
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
See Also: → 1060965
This issue has been verified successfully on Flame 2.0,2.1

See attachment: Verify_image.png
Reproducing rate: 0/5
Flame 2.0 versions:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/29222e215db8
Build-ID        20141203000201
Version         32.0
Flame 2.1 versions:
Gaia-Rev        dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebce587d2194
Build-ID        20141203001205
Version         34.0
Attached image Verify_image.png
You need to log in before you can comment on or make changes to this bug.