Closed Bug 1045746 Opened 10 years ago Closed 10 years ago

Awesome bar suggestions interfere with text entry

Categories

(Firefox for Android Graveyard :: Awesomescreen, defect)

ARM
Android
defect
Not set
normal

Tracking

(fennec33+)

RESOLVED WORKSFORME
Tracking Status
fennec 33+ ---

People

(Reporter: jimb, Assigned: jchen)

References

()

Details

(Keywords: regression)

In Aurora 33.0a2 dated 2014-07-29, awesome bar completion causes typing a second letter to delete the first letter entered. The attached link is for a video that shows what's going on.

In case the video isn't visible:

- I tap in the awesome bar, to begin entering a search term. My page disappears, and I see the "top sites" list and the on-screen keyboard, which is as expected.

- I type "a", and "amazon.com/" appears in the awesome bar. "mazon.com" is selected in blue, and the "/" is selected in amber.

- I type "m", and all the text in the awesome bar, including the "a" I first typed, is replaced by an "m", with no selection and the insertion point sitting after the m.
tracking-fennec: --- → ?
What keyboard are you using?
Flags: needinfo?(jimb)
My settings says "HTC Sense Input". It's the stock keyboard that came with my phone.
Flags: needinfo?(jimb)
Assignee: nobody → nchen
tracking-fennec: ? → 33+
It appears the HTC keyboard does URL autocompletion on top of Fennec's URL autocompletion, and the conflict breaks things altogether.

Rather than trying to blacklist HTC or putting on a bandaid fix, I think it makes more sense to have an option to disable URL autocompletion in the settings? We've had requests for this setting before. What do you think, Wes?
Status: NEW → ASSIGNED
Flags: needinfo?(wjohnston)
(In reply to Jim Chen [:jchen :nchen] from comment #3)
> It appears the HTC keyboard does URL autocompletion on top of Fennec's URL
> autocompletion, and the conflict breaks things altogether.
> 
> Rather than trying to blacklist HTC or putting on a bandaid fix, I think it
> makes more sense to have an option to disable URL autocompletion in the
> settings? We've had requests for this setting before. What do you think, Wes?

Couldn't we just tell Android that that's not a URL field, since we do our own URL handling?
(In reply to Jim Blandy :jimb from comment #4)
> (In reply to Jim Chen [:jchen :nchen] from comment #3)
> > It appears the HTC keyboard does URL autocompletion on top of Fennec's URL
> > autocompletion, and the conflict breaks things altogether.
> > 
> > Rather than trying to blacklist HTC or putting on a bandaid fix, I think it
> > makes more sense to have an option to disable URL autocompletion in the
> > settings? We've had requests for this setting before. What do you think, Wes?
> 
> Couldn't we just tell Android that that's not a URL field, since we do our
> own URL handling?

Last time we looked into it. A lot of keyboards show additional keys like ".com" when we tell them it's a URL field, and users are used to those keys.
I guess we can try turning off URL mode for HTC keyboards specifically.
Sorry for the delay. I don't mind a setting for this. I doubt the people affected would find it though, but at least it would give us something to advise them on. Hooking up browser.urlbar.autocomplete.enabled and then advising people to use about:config would probably have just as much effect.

TBH, I'd prefer to just maintain a blacklist of keyboards to turn this off for than to try and use hacks to fix it.
Flags: needinfo?(wjohnston)
JimB - Can you test these?
The bug is also fixed in nightly.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.