Closed Bug 1045777 Opened 5 years ago Closed 5 years ago

Implement task card to represent each task switcher entry

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
All
defect
Not set

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.1 S4 (12sep)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: sfoster, Assigned: sfoster)

References

Details

(Whiteboard: [ft:systems-fe][systemsfe])

User Story

As a user I want to be able to clearly see a description of the content in Task Manager to help me identify the apps.

1. When viewing task manager, I can see a description associated with the content, matching the UX spec.

Attachments

(1 file)

Each card in the new task switcher is an overlay of the AppWindow, with buttons/actions to open app, close app and favorite app. 

Spec: https://mozilla.app.box.com/s/m8lnw8mbx0dy3rawdhuo

This work is underway already in https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/task_card.js
This work is intrinsically linked to bug 1045784 - we need a card representation to build the task strip, but exactly what that needs to be depends on the implementation we settle on for that task strip. We may end up duping this as we can't land a task strip without at least all the existing functionality being present.
Assignee: nobody → sfoster
Target Milestone: --- → 2.1 S1 (1aug)
Target Milestone: 2.1 S1 (1aug) → 2.1 S2 (15aug)
feature-b2g: --- → 2.1
Target Milestone: 2.1 S2 (15aug) → 2.1 S3 (29aug)
feature-b2g: 2.1 → 2.2?
Target Milestone: 2.1 S3 (29aug) → 2.1 S4 (12sep)
Fixed in bug 1061324, https://github.com/mozilla-b2g/gaia/commit/b3698e7e93b5945b5aa5f857dd01932894f57a85

See follow-up bug 1065431 for adding favorite/bookmark button
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
feature-b2g: 2.2? → 2.2+
Following this UX Spec:
https://mozilla.app.box.com/s/m8lnw8mbx0dy3rawdhuo

Verifying fix in 3.0 (mozilla-central) on flame devices.
Results: Task Manager cards display their title, app icon and browser url (if a browser page). 
Worth noting that zombie apps do not display as a white card (as described in the spec), but rather display their screenshot until they reopen and the app restarts. This seems to be intended behavior from comment # 10 and 11 in bug 935750 by Alive.

--------------------------------------------------
Environmental Variables:
Device: Flame 3.0
BuildID: 20150209010211
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 3436787a82d0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
--------------------------------------------------
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Adding verifyme for 2.2 verification.
Keywords: verifyme
This issue has been verified successfully on latest Flame2.2
STR:
1. Launch some of the APP in home screen.
2. Long press "Home" key to invoke card view.
**You can see the same phenomenon with comment 3
Verify video:"verify_1045777.mp4".

Flame 2.2 build:
Build ID               20150210002516
Gaia Revision          b30c8e4303595a0fcb5b640d673cf8503b954701
Gaia Date              2015-02-10 04:09:47
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3e9fa4e70a1b
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150210.041059
Firmware Date          Tue Feb 10 04:11:10 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.