If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crashes on javascript link

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Rob Lowrie, Assigned: Adam Lock)

Tracking

({crash, pp})

Trunk
Future
x86
Linux
crash, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
Go to the URL and for any of the items listed, click on the "magnifying glass".
A new window is created, which soon disappears, and then typically the entire
browser crashes (sometimes, the browser does _not_ crash, but try it a few times).
wfm with win2k build 20011011..

Reporter: 
Please include in all bug reports the build ID !
Can you use a talkback enabled build and poste the talkback ID of that crash ?

Comment 2

16 years ago
bug confirmed with build 2001101221 linux

Comment 3

16 years ago
wfm using build 2001101203 on Win2k. The popup windows does not disappear for me.
(Reporter)

Comment 4

16 years ago
...sorry. Build ID is 2001101202 on linux.
-> Dom0

and confirming based on the comments
Assignee: rogerl → jst
Status: UNCONFIRMED → NEW
Component: Javascript Engine → DOM Level 0
Ever confirmed: true
QA Contact: pschwartau → amar

Comment 6

16 years ago
I do not crash on WinNT, only on Linux. Will attach stack trace.

Comment 7

16 years ago
Created attachment 53497 [details]
Linux stack trace of crash

Comment 8

16 years ago
Comment on attachment 53497 [details]
Linux stack trace of crash

Wrong attachment; sorry
Attachment #53497 - Attachment is obsolete: true

Comment 9

16 years ago
Created attachment 53498 [details]
Linux stack trace of crash

Comment 10

16 years ago
Based on the stack trace, I would like to send this to Embedding:Docshell
for further analysis - 
Assignee: jst → adamlock
Component: DOM Level 0 → Embedding: Docshell
QA Contact: amar → adamlock

Comment 11

16 years ago
Here is the HTML for a "magnifying glass" link at the site:

<a href="javascript:;" 
   onClick="JustSoPicWindow('images/pitchers_all_lg.jpg','382','175',
           '* * Click screen to close * *','#FFFFFF','hug image','5');
           return document.MM_returnValue">

<img src="../graphics/icon_details.gif" 
     width="22" height="39" align="absmiddle" border="0">

</a>


That looks pretty goofy to me: the href="javascript:;" together with
a JS function on the onClick() event...
(Assignee)

Comment 12

16 years ago
The javascript:; thingy looks familiar to some problems we were once had with
other javascript: URLs e.g., "javascript:2+2" I'll see if I can find the
original bug to see if it sheds light on this issue.
(Assignee)

Comment 13

16 years ago
-> 0.9.7

Never found that previous JS problem.
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 14

16 years ago
-> 1.0.1
Target Milestone: mozilla0.9.7 → mozilla1.0.1

Comment 15

16 years ago
I'm using mozilla 1.0 on linux.
I point the browser to url logosol.com.
Website asks me to get java plugin.
I installed sun's jre/java plugin.
Now when I point mozilla to logosol.com the browser crashes.
If I remove libjavaplugin_oji140.so from /usr/local/mozilla/plugins 
and restart mozilla I can once again go to site logosol.com without 
browser crashing.

Comment 16

16 years ago
I think that on Linux it is essential in /usr/local/mozilla/plugins
to have a SYMLINK to libjavaplugin_oji140.so, not the file itself -

See http://bugzilla.mozilla.org/show_bug.cgi?id=133795#c51

Comment 17

15 years ago
Changing target milestone to 'Future' since 'mozilla1.0.1' came and went already.
Target Milestone: mozilla1.0.1 → Future

Comment 18

15 years ago
This is a rather old bug. Reporter (Rob Lowrie), does this problem exist with a
newer build?
Severity: normal → critical
Keywords: crash, pp
(Assignee)

Comment 19

14 years ago
Javascript href / onclick has recently changed. A recent Linux trunk build WFM
so I am marking such.

Please reopen if the problem can be reproduced. BTW I'm referring to the problem
that the bug was opened for, not the logosol.com thing at the bottom which
should live in its own bug.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.