Closed Bug 1045906 Opened 8 years ago Closed 8 years ago

thedailybeast.com progress bar animation is very jumpy

Categories

(Core :: Layout, defect)

30 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1048838
Tracking Status
firefox32 --- unaffected
firefox33 + fixed
firefox34 + fixed

People

(Reporter: cpeterson, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

STR:
1. Load http://www.thedailybeast.com/articles/2014/05/29/renewables-can-make-fossil-fuel-more-efficient.html
2. Slowly scroll down the page.
3. Watch the "READ THIS.list" section on the right side of the page. As the page scrolls, a gray progress bar fills the "READ THIS.list" section.

RESULT:
In Firefox 33, the progress bar is very jumpy. In Firefox 32, it's smooth. I'm running OS X on a Retina/HiDPI MBP.
Brian, I bisected this regression in Nightly 33 build 2014-06-21 to this mozilla-inbound pushlog that only includes your fix for CommonElementAnimationData bug 1025709:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e9118a2be9b3&tochange=2c21b94a7775
Blocks: 1025709
Flags: needinfo?(birtles)
I can reproduce this on Windows 8 too. It definitely seems like I regressed this in bug 1025709 but I'm not sure yet how.

This might take a while to debug and I'm away on PTO after tomorrow. If anyone else is able to look into it in the meantime, please feel free!
Flags: needinfo?(birtles)
OS: Mac OS X → All
Hardware: x86 → All
Component: Graphics → Layout
Attached file testcase
Regression. Tracking
Seems likely to be the same bug as 1048838, which has a little more analysis.
Depends on: 1048838
Fixed by bug 1048838.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1048838
You need to log in before you can comment on or make changes to this bug.