Closed Bug 1045914 Opened 8 years ago Closed 8 years ago

JavaScript Warning: "Error in parsing value for 'top'. Declaration dropped." {file: "app://camera.gaiamobile.org/index.html" or JavaScript Warning: "Error in parsing value for 'bottom'. Declaration dropped." {file: "app://camera.gaiamobile.org/index.htm

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gkw, Assigned: justindarc)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1037780 +++

Turn on Lockscreen via Settings, turn off display, turn it on again. Instead of swiping right to unlock, swipe left to go into the Camera app instead. On or around the time the permissions dialog comes up - I chose not to share but also not remember this setting, the following JS warnings show up:

E/GeckoConsole( 1107): [JavaScript Warning: "Error in parsing value for 'top'.  Declaration dropped." {file: "app://camera.gaiamobile.org/index.html" line: 0 column: 0 source: "NaN%"}]
E/GeckoConsole( 1107): [JavaScript Warning: "Error in parsing value for 'bottom'.  Declaration dropped." {file: "app://camera.gaiamobile.org/index.html" line: 0 column: 0 source: "NaN%"}]

$ ./check_versions.sh
Gaia      295967a0b824a355ae9d57fb08f3632ed2ad18dd
Gecko     https://hg.mozilla.org/mozilla-central/rev/a4dcfbebcb58
BuildID   20140728040209
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
Summary: JavaScript Warning: "Error in parsing value for 'top'. Declaration dropped." {file: "app://camera.gaiamobile.org/index.html" or JavaScript Warning: "Error in parsing value for 'bottom'. Declaration dropped." → JavaScript Warning: "Error in parsing value for 'top'. Declaration dropped." {file: "app://camera.gaiamobile.org/index.html" or JavaScript Warning: "Error in parsing value for 'bottom'. Declaration dropped." {file: "app://camera.gaiamobile.org/index.htm
Assignee: nobody → jdarcangelo
Appears to have been caused by Bug 1038172
Attached file pull-request (master)
Tiny fix for regression introduced by Bug 1038172
Attachment #8464928 - Flags: review?(dmarcos)
Attachment #8464928 - Flags: review?(dmarcos) → review+
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/dd7e13eb8c6a50a72b447c92eddbe92f6fc655c5
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.