Thai Language, when displayed in a pdf, is generated with "error" characters

VERIFIED FIXED in Firefox 39

Status

()

Firefox
PDF Viewer
P3
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: shane, Unassigned)

Tracking

({regression})

31 Branch
Firefox 39
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/5882 [bugday-20150617], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8464924 [details]
Thai_FF31_Errors.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Opened a PDF in a new tab via a site my company made.


Actual results:

File opened, but with 'errors' - There were no errors when I was using a previous version of FireFox (29 or 30??) But then I updated and now I get these squares all over when other browsers with a built in PDF viewer (chrome) do not display the characters with errors.


Expected results:

Open without errors... like chrome.
(Reporter)

Updated

3 years ago
Component: Untriaged → PDF Viewer

Updated

3 years ago
Keywords: regressionwindow-wanted
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion]

Comment 1

3 years ago
pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a4ac15d6912d&tochange=3831f8e22e30
Suspect:
e1d196155712	Ryan VanderMeulen — Bug 990852 - Update pdf.js to version 0.8.1334. r=yury, r=Mossop
Blocks: 990852
Keywords: regressionwindow-wanted → regression
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Reproduced on latest Nightly 20140806030201, setting as New.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is a regression from commit https://github.com/mozilla/pdf.js/commit/b5b94a4af389ef387570cf22662d9fc6bd41417a (i.e. PR https://github.com/mozilla/pdf.js/pull/4259).
Created attachment 8469201 [details]
Reduced testcase
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion] → [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/5882
Depends on: 1148192
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 39
QA Whiteboard: [good first verify]

Comment 5

3 years ago
Successfully reproduce this bug in Firefox 38.0.5 Build ID: 20150525141253.

The fix works for me on 

Firefox 41.0a1, build ID: 20150617030205 , User agent: Mozilla/5.0 (Windows NT 6.1; rv:41.0) Gecko/20100101 Firefox/41.0 .

Firefox 40.0a2 build ID: 20150612004006 , User agent: Mozilla/5.0 (Windows NT 6.1; rv:40.0) Gecko/20100101 Firefox/40.0
QA Whiteboard: [good first verify] → [good first verify][bugday-20150617]
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/5882 → [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/5882 [bugday-20150617]

Updated

3 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.