[e10s] Crash when using "ScrapBook" add-on's DOM Eraser: Assertion (!DispatchingUrgentMessage()) failed. sync messages forbidden while handling urgent message

RESOLVED DUPLICATE of bug 1010737

Status

()

--
critical
RESOLVED DUPLICATE of bug 1010737
4 years ago
4 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({addon-compat, crash})

34 Branch
x86_64
Windows 7
addon-compat, crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox33 wontfix, firefox34 affected)

Details

(crash signature)

(Reporter)

Description

4 years ago
Tab crashed when click a page using 
bp-f54a9d53-0ad2-4540-b554-d43ec2140730

Steps To Reproduce:
1. Enabled e10s autostart
2. Install ScrapBook 1.5.9 https://addons.mozilla.org/en-US/firefox/addon/scrapbook/
   And restart
3. Open https://www.mozilla.org/en-US/firefox/help/
4. Alt, select ScrapBook > Save Page As...
5. Save
6. Alt, select ScrapBook > Firefox Help (which is saved at step 5) 
7. Click "DOM Eraser" icon at the bottom toolbar
8. Click one of a topic conainer to remove
9. Repeat step 8 if necessary

Actual Results:
Tab crashed

Expected Results:
No crash:
###!!! [MessageChannel][Child][/builds/slave/m-cen-osx64-ntly-0000000000000/build/ipc/glue/MessageChannel.cpp:585] Assertion (!DispatchingUrgentMessage()) failed.  sync messages forbidden while handling urgent message 
  MessageChannel 'backtrace':
  [(0) in async ???(actor=2) ]
  [(1) out async PJavaScript::Msg_CallOrConstruct(actor=-4) ]
  [(2) out sync PBrowser::Msg_GetInputContext(actor=2) ]
  remote Interrupt stack guess: 0
  deferred stack size: 0
  out-of-turn Interrupt replies stack size: 0
  Pending queue size: 0, front to back:
[Child 32884] ###!!! ABORT: sync messages forbidden while handling urgent message: file /builds/slave/m-cen-osx64-ntly-0000000000000/build/ipc/glue/MessageChannel.cpp, line 1739
Blocks: 899758
Mentor: cpeterson
status-firefox33: --- → wontfix
status-firefox34: --- → affected
tracking-e10s: --- → ?
Keywords: crash
Summary: [e10s] Tab crashed when using DOM Eraser of "ScrapBook" add-on → [e10s] Crash when using "ScrapBook" add-on's DOM Eraser: Assertion (!DispatchingUrgentMessage()) failed. sync messages forbidden while handling urgent message
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1010737
tracking-e10s: ? → +
You need to log in before you can comment on or make changes to this bug.