Don't keep asking about downloading uninstalled plug-ins

VERIFIED DUPLICATE of bug 69215

Status

()

Core
Plug-ins
VERIFIED DUPLICATE of bug 69215
17 years ago
17 years ago

People

(Reporter: Peter De Wachter, Assigned: av (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    200110202

When you visit a site which uses a plug-in you haven't installed, Mozilla pops
up a dialog saying: "This page blabla can only be viewed with the appropriate
Plug-in. Click OK to download Plug-in."

This dialog has "Ok" and "Cancel" buttons. It should also have a "Cancel, and
never ask me about this plug-in again" button.

(BTW, in the dialog "CANCEL" and "Plug-in" shouldn't be capitalised, and it
there should be a "the" between "download" and "Plug-in".)

Reproducible: Always
Steps to Reproduce:
1. Make sure the Flash plug-in isn't installed.
2. Go to a site which uses Flash but shouldn't (such as
http://www.fashioncomputers.com/)
3. Answer "Cancel" to the dialog
4. Go to another site which uses Flash, such as http://www.media.mit.edu/characters/


Actual Results:  Mozilla asks again about the Flash plug-in. I get irritated.

Expected Results:  Mozilla should just show the "no plug-in installed" icon,
like it would do when you click Cancel. It should only ask about downloading
when you click that icon. (And scrolling with the mouse-wheel doesn't count as
clicking.)

*** This bug has been marked as a duplicate of 69215 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.