"Faster Video" add-on's context menu submenu does not work with e10s after restarting Firefox

RESOLVED DUPLICATE of bug 1060138

Status

()

RESOLVED DUPLICATE of bug 1060138
4 years ago
4 years ago

People

(Reporter: alreiten, Unassigned)

Tracking

({addon-compat})

34 Branch
x86_64
Windows 7
addon-compat
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

4 years ago
STR:
1 open new profile
2 install addon from https://addons.mozilla.org/en-US/firefox/addon/faster-video/
3 set browser.tabs.remote.autostart to true
4 restart
5 go to youtube, start playing any html5 video
6 right click page

Expected Results: context menu should show current video speed (1X), with the option to change the speed to various preset or incremental levels

Actual Results: context menu does not display any info from addon
alreiten, thanks for testing! I'll update our list of add-ons.
Blocks: 905436
Mentor: cpeterson
tracking-e10s: --- → +
Keywords: addon-compat
This plugin is working now for me in Nightly with e10s windows. alreiten, are you still seeing the issue?
Thanks!
Flags: needinfo?(alreiten)
(Reporter)

Comment 3

4 years ago
I tested it again--it seemed to work.  Then Nightly updated, and I tried again--now it is not working??

I then tried it out in a fresh new profile--the context menu still does not display the add-on controls.
(Reporter)

Comment 4

4 years ago
I tested again; got it working right after initial installation on a new profile.  After restarting Nightly, the add-on would not even show the context menu when playing html5 video.  There seems to be a consistent pattern:  reinstalling the add-on would allow for the context menu to show only until the next restart, when it would again disappear.
Flags: needinfo?(alreiten)
alreitan, is E10S enable both before and after the restart? Do you perhaps have E10S disabled and then reboot after installing the add-on and enabling E10S? That might explain why the add-on works before rebooting (because E10S won't be enabled until after the restart).
(Reporter)

Comment 6

4 years ago
Chris, I think that might explain it.  I tried again, making sure to have E10s enabled with restart before installing the addon.  So...

1 Created new profile.
2 Enabled E10s.
3 Restarted
4 Installed Add-on.
5 The context menu submenu for the addon will now show up on right click, but clicking on any of the speeds doesn't do anything to the html5 video speed.
6 Restart
7 The context menu submenu will not show up.
8 Installed Add-on again (on top of itself).
9 The context menu submenu for the addon will now show up on right click, but clicking on any of the speeds doesn't do anything to the html5 video speed.
10 Restart
11 The context menu submenu will not show up.
Interesting. Thanks for testing, alreiten!

Dave: Is Firefox using different code paths to load a restartless add-on when it is first installed and when it is loaded when launching the browser? Does this sound like a bug in the add-on, the Add-on SDK, or Firefox itself?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(dtownsend+bugmail)
Summary: "Faster Video" add-on does not work with e10s → "Faster Video" add-on's context menu submenu does not work with e10s after restarting Firefox
context-menu doesn't support e10s at the moment.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(dtownsend+bugmail)
Resolution: --- → DUPLICATE
Duplicate of bug: 1060138
You need to log in before you can comment on or make changes to this bug.