Closed Bug 1046592 Opened 8 years ago Closed 8 years ago

Mute option in browser doesn’t work properly.

Categories

(Core :: Audio/Video, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla34
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected

People

(Reporter: juanjose.iglesias, Assigned: padenot)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Step to reproduce the issue: 
1.	Open browser app. 
2.	Go to youtube (http://www.youtube.com)
3.	Play a video in browser window.
4.	Try to mute the video sound pressing the mute button. 

TESTED WITH: 

Flame master , Gecko 10853dd and Gaia cc5af5e.

Tested using unagi 1.3 and unagi 2.0, this option worked properly. 



Actual results:

The video sound isn’t muted. This happens with video is showing in fullscreen or in normal size. 


Expected results:

The video sound should be muted when you pressing the mute button.
I am seeing this issue on todays 2.1 Flame 319MB

Environmental Variables:
Device: Flame Master 319MB
Build ID: 20140804040204
Gaia: 5fd14b8bc428f87f9b5cf9cc49f9a4f362a970fb
Gecko: e6614d8d85f9
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: UNCONFIRMED → NEW
QA Whiteboard: [QAnalyst-Triage?]
Ever confirmed: true
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:

Buttons should always function properly when tapped so nominating this 2.1? This is also a regression from 2.0
blocking-b2g: --- → 2.1?
Component: Gaia → Gaia::Browser
QA Contact: pcheng
Component: Gaia::Browser → Video/Audio
Product: Firefox OS → Core
Mozilla-inbound regression window:

Last Working Environmental Variables:
Device: Flame
Build ID: 20140729092306
Gaia: 449d632c69b1a4bd5101d07d18f76799d3fd5f38
Gecko: eefad3e4e594
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken Environmental Variables:
Device: Flame
Build ID: 20140729094539
Gaia: 449d632c69b1a4bd5101d07d18f76799d3fd5f38
Gecko: 3e28cd6f2ab8
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Gaia is the same again, so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=eefad3e4e594&tochange=3e28cd6f2ab8

There are quite a few audio related commits. All from the same author.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Paul - this pushlog is all your work - could you take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(paul)
Yeah.
Assignee: nobody → paul
Flags: needinfo?(paul)
Not sure what I was thinking at the time.
Attachment #8469455 - Flags: review?(kinetik)
Attachment #8469455 - Flags: review?(kinetik) → review+
The commits here seem to be the root cause for bug 1052923. Reverting both of them fixes the problem however I'm unsure if the issue is really caused by this or we miscalculated the volume in the gaia application in the first place.
This landed before uplift, so it's already in v2.1.
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.