Closed Bug 1046819 Opened 7 years ago Closed 6 years ago

Provide a way for the OS to tell Firefox to flush its DNS cache

Categories

(Core :: Networking: DNS, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1008091

People

(Reporter: elad, Unassigned)

Details

As part of the ongoing GNOME Safety/Privacy efforts, we are working on improving captive portal handling.

We have a captive portal detection mechanism in our OS that will show the captive portal login dialog when the user connects to one. The problem is, the DNS cache might be poisoned (until the TTL expires) by the portal before the user logins, and that would mean the user will get "invalid certificate" errors for many websites - and might even click "add an exception" for those errors which is NOT a thing we want them to do.

See:
https://bugzilla.gnome.org/show_bug.cgi?id=734050

We need a way to tell Firefox to flush its DNS cache after the user logins to the captive portal. Is there a way for us to do this? If not, can you add a way for us to do this?
Component: Untriaged → Networking: DNS
Product: Firefox → Core
Summary: Does Firefox provide a way for the OS to tell it to flush the DNS cache? → Provide a way for the OS to tell Firefox to flush its DNS cache
Sounds like Bug 1008091 to me. Sending the changed network event is probably the better way, as there can be more than DNS caches to deal with.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1008091
You need to log in before you can comment on or make changes to this bug.