Cannot enter "Brussels, Belgium" as my city in my Mozillian profile because the Search provides no Region

RESOLVED DUPLICATE of bug 1134156

Status

Participation Infrastructure
Phonebook
--
major
RESOLVED DUPLICATE of bug 1134156
4 years ago
3 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

Details

Trying to edit my Mozillian profile:

- There are no input fields for city and region
- When I search for "Brussels" on the map I get only US cities. "Bruxelles" also suggests Bruxelles, Belgium and if I select that it fills in the "City" field but not the "Region" field.
- The correct "Region" in this case would be "Brussels Capital Region" or in French "Région de Bruxelles-Capitale" but AFAICT there's no way to enter that
- If I try to save, I get "Please correct the errors below" and "Region must also be saved if city is saved"
- My actual township is Schaerbeek, but the map search doesn't know about it. How could I set "City: Schaerbeek (or maybe Brussels); Region: Brussels (or Brussels-Capital); Country: Belgium" (or the French equivalents)? AFAIK, I can't.
- Please don't tell me (as some people have in the past) that Brussels is in the "Flanders" region: it isn't. The 19 municipalities of Brussels constitute one distinct Region, named in French "Région de Bruxelles-Capitale" or in Dutch "Brussels Hoofdstedelijk Gewest". My mother language is French but over the Internet I prefer to use English.
Oh, I forgot:

Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 SeaMonkey/2.27a1 ID:20140214003001 c-c:1ce77c2f9bd0 m-c:d275eebfae04
Hm, I get a valid search result when entering 'Brussel'. Maybe that would work for the moment?
MapBox has a way to report missing information. Could you share the proper city name with MapBox? Directions are explained here 
https://wiki.mozilla.org/Mozillians/Locations

Thanks for your help, Tony and Henrik!
(In reply to Henrik Skupin (:whimboo) [away 08/16 - 08/23] from comment #2)
> Hm, I get a valid search result when entering 'Brussel'. Maybe that would
> work for the moment?

With either "Bruxelles" or "Brussel" I get search results for "Bruxelles, Belgium" or "Brussel, Belgium" respectively, but in both cases the "Region" field is empty. If I try to save the modified profile, I get a red error message saying that the "Region" is required is there is a city name. So I cannot save my hometown in my profile.

(In reply to William Reynolds [:williamr] from comment #3)
> MapBox has a way to report missing information. Could you share the proper
> city name with MapBox? Directions are explained here 
> https://wiki.mozilla.org/Mozillians/Locations
> 
> Thanks for your help, Tony and Henrik!

I'll try. Or could you make the "no City without Region" requirement less absolute? Some people would feel that "(City) Bruxelles (Region) Bruxelles-Capitale (Country) Belgium" is ridiculous or redundant; yet it is the only correct non-empty French-language Region for Brussels. Some Flemish nationalists want "Vlaanderen" as the Dutch-language Region for the City of "Brussel", yet the correct Region in Dutch is not that but (in full) "Brussels Hoofdstedelijk Gewest"(where "Brussels" with -s is a Saxon genitive) or (in short) "Brussel-Hoofdstad".
The OpenStreetMap node http://www.openstreetmap.org/node/1635651356 for the city of "Bruxelles" includes key "is_in:Region" value "Brussels-Capital Region". Nothing to do.

The Mozillians site won't take that. So what can I do?
Summary: Cannot enter "Brussels, Belgium" as my city in my Mozillian profile → Cannot enter "Brussels, Belgium" as my city in my Mozillian profile because the Search provides no Region
Wray any ideas why the region is not populated?
Flags: needinfo?(wbowling)
I'm investigating this and bumping into a lot of the same things you're all mentioning above. I'll get to the bottom of this issue! It's important to solve because it will set a precedent for how we handle future similar issues.
Flags: needinfo?(wbowling)
I got in touch with mapbox support. their geocoding API may have a bug. the issue has been filed with them. Here's a summary of what is happening as my copy-pasted email to support:

The error is easily reproducible. On this demo page https://www.mapbox.com/mapbox.js/example/v1.0.0/geocoder-keep-open/ type in "brussels" which will return the following list:
Brussels, 54204, Wisconsin, United States
Brussels, 62013, Illinois, United States
Brussels Road, Brussels, 54204, Wisconsin, United States
Brussels Road, Brussels, 54204, Wisconsin, United States
Brussels Road, Brussels, 54204, Wisconsin, United States
searching "Bruxelles" returns
Brussels, Belgium
Brussels, Belgium
the difference between those two entries matches the OSM data. This is the data for those two entries, neither of which include region

[
  [
    {
      "id": "mapbox-places.10968019",
      "bounds": [
        4.241666000000014,
        50.755356,
        4.583176000000009,
        50.94285200000001
      ],
      "lon": 4.408196,
      "lat": 50.852516,
      "name": "Bruxelles",
      "type": "city"
    },
    {
      "id": "country.1799115933",
      "name": "Belgium",
      "type": "country"
    }
  ],
  [
    {
      "id": "mapbox-places.32656665",
      "bounds": [
        4.345601999999998,
        50.83731100000001,
        4.369774000000005,
        50.85220700000001
      ],
      "lon": 4.354238,
      "lat": 50.844344,
      "name": "Bruxelles",
      "type": "city"
    },
    {
      "id": "country.1799115933",
      "name": "Belgium",
      "type": "country"
    }
  ]
]

I hope that explains the problem more clearly. Brussels is part of the Brussels-Capitol Region which is not represented. On Mozillians, we are requiring that users have their region specified if they wish to specify their city. Is that is a fool's errand? We would like to correct the data on OSM so it is correct for everyone.

---

Their response:
Ah! I see. Thanks, this will need to be change we make to the geocoder. I have filed a ticket referencing this to address the issue.
issues are posted here, evidently: https://github.com/mapbox/carmen/issues
What if a country has no regions?
I think the region defaults to the name of the country. Legally, I am sure you are right that some countries have no regions. I'll make this list of likely candidates and start testing them tomorrow to make sure. Most are small islands.

Bahrain, Benin, Brunei Darussalam, Lesotho, Malawi, Malta, Mauritius, Micronesia, Nauru, Oman, Palau, Qatar, St Kitts and Nevis, St Vincent and the Grenadines, San Marino, Seychelles, Sierra Leone, Suriname, Swaziland, Timor-Leste, Tonga, Turkemenistan, Vanuatu.
:tonymec(In reply to Tony Mechelynck [:tonymec] from comment #11)
> What if a country has no regions?

That was an excellent point, Tony. It took me very little time to find countries without regions now that I've tested a few and cross-checked them on Wikipedia. Bahrain, first one right off from the start has no regions. It's far too small to warrant them.

It's a good time to rethink our location requirements for the edit profile form. Thank you Tony for your detective work.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134156
:tonymec I'd like to let you know that the error in OSM was fixed this week. http://www.openstreetmap.org/note/227046#map=15/50.8460/4.3523
You need to log in before you can comment on or make changes to this bug.