Closed Bug 1046954 Opened 8 years ago Closed 5 years ago

Bookmarks file structure not perserved on merge of two accounts on same computer

Categories

(Firefox :: Sync, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1323333

People

(Reporter: guigs, Unassigned)

References

Details

(Whiteboard: [sync:bookmarks])

When you switched over to the new account, when you set it up the profile was blank and the name was: "uglings Firefox auf home1-ugling". Then on another login for the same computer, the name on the account was the same, so you changed the name. 

So when you added bookmarks on the newly named computer account (the restricted account), all of the bookmark folders disappeared.
Summary for clarification, sorry for the repetitiveness. 

STR: 
# unlink account from old sync
# create new windows account on same computer
# on new account create sync account that has a blank profile and wait to sync.  name is CILBMHVM6DT
# go to the previous windows account and add the new sync account to the old profile. (i did get a warning that there was an older account that was signed into, but I hit sync anyway) name was WIN-CILBMHVM6DT 

# Wait for it to sync. 
# rename the computer name associated with sync on old profile because it has the same name.(renamed old one to WIN-2)
# Add bookmarks to new windows account
# Go back to old windows account and see the new folder, but some previous folders are missing and bookmarks are out of their original folder. 

Expected: 
Merged folders to remain same file structure

Results: 
Some bookmarks are not in folders that no longer appear in the bookmarks toolbar folder.
Component: Sync → Firefox Sync: Backend
Product: Firefox → Mozilla Services
Version: 31 Branch → unspecified
Whiteboard: [sync:bookmarks]
Blocks: 621584
Our deduping logic gets this wrong. :-( Tracking in bug 1323333.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1323333
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.