window.close should close just the tab rather than entire window

VERIFIED DUPLICATE of bug 103452

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 103452
17 years ago
10 years ago

People

(Reporter: WD, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

With many tabs open, I came across a page that used JS window.close
Rather than closing just the tab, it closed my Mozilla window, bringing down all
other tabs with it.   If tabs are currently being used, then window.close should
close only the active tab.

Reproducible: Always
Steps to Reproduce:
1.Open a couple tabs (Ctrl-T)
2.Go to a page that uses window.close (sorry... don't have an example)
3.

Actual Results:  The whole mozilla window is closed

Expected Results:  Just the tab with the page that uses window.close is closed

Comment 1

17 years ago
dupe of bug 103452?

*** This bug has been marked as a duplicate of 103452 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.