If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Click to Play per-element" add-on does not work with e10s

RESOLVED FIXED

Status

()

Firefox
Extension Compatibility
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: alreiten, Unassigned)

Tracking

({addon-compat})

34 Branch
x86_64
Windows 7
addon-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

3 years ago
STR:
Create new profile
Change Shockwave Flash plugin in Addon Manager to Ask to Activate
Set browser.tabs.remote.autostart in about:config to true
Install Click to Play per-element from https://addons.mozilla.org/en-US/firefox/addon/click-to-play-per-element/
Restart
Go to any page with flash objects--I used https://www.adobe.com/software/flash/about/
Try to play either of the flash objects

Results: flash object would not play when clicked; clicking did nothing

Also, the plugin button in the address bar which can enable flash for the entire page (even with this addon) was not present.

Expected Results: each individual flash object would play when clicked, without enabling flash for the whole page

The plugin button should be in the address bar.
Thanks, alreiten! I'll update our list of add-ons.
Blocks: 905436
Mentor: cpeterson@mozilla.com
tracking-e10s: --- → +
Keywords: addon-compat

Comment 2

3 years ago
I use this plugin myself, and love it.  However, click-to-play does not work with e10s yet according to Bug 899347, which is why this addon appears broken. Although it is possible that this addon really is broken in e10s, we probably won't know for sure until Bug 899347 lands.
As Trevor suggested, let's retest after bug 899347 lands.
Status: UNCONFIRMED → NEW
Depends on: 899347
Ever confirmed: true

Comment 4

3 years ago
bug 899347 landed and result is very simple.
"Click to Play per-element" add-on does not work completely because gPluginHandler interface was reconstructed.
("Click to Play per-element" add-on depends on some old-gPluginHandler functions)

Comment 5

3 years ago
New version was released and it doesn't work with e10s as per author's comment.

Updated

3 years ago
Duplicate of this bug: 1101154
The developer has been contacted through AMO.

Comment 8

3 years ago
Has any progress been made with this bug? This is the only feature blocking me from daily using e10s.
The developer isn't interested in continuing development of the add-on, and the listing on AMO is asking for help from anyone who wants to step up.

Comment 10

3 years ago
"I don't know how to do this add-on working with multiprocess Firefox (e10s). If someone wants to continue (or help) the development this addon please send me an email."

So the addon developer doesn't even know how.

Comment 11

3 years ago
This add-on implements functionality that was in a pre-release version of Firefox and would be dearly missed. I would really appreciate it if Mozilla supported or even continued development and provided sec-review. *Please!*

Comment 12

3 years ago
(In reply to Jorge Villalobos [:jorgev] from comment #9)
> The developer isn't interested in continuing development of the add-on, and
> the listing on AMO is asking for help from anyone who wants to step up.

I know. But I would figure that someone who knows how would step in. I guess not.

Comment 13

3 years ago
new working version will come soon (compatible with e10s)
The add-on now works correctly.

Thanks!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.