[v2.1] Feature Proposal: Message Received / Message Read Notice in Messages App

RESOLVED DUPLICATE of bug 1010093

Status

Firefox OS
Gaia::SMS
--
enhancement
RESOLVED DUPLICATE of bug 1010093
4 years ago
4 years ago

People

(Reporter: Brett Edmond Carlock, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8466037 [details]
2014-08-01-03-57-15.png

I'd like to see the Messages App in FFXOS display a pictographic representation of the message's status along the same lines as the Green Check / Red Exclamation mark that currently exist to show the user whether or not the message was sent successfully.

I'd like for the Messaged Received notification to be something like >|, a simple representation.

I'd like for the Message Read notification to be an eye-like symbol if a character representation isn't feasible.

In one method of display, the icons would stack vertically in a logical order and would fill in one by one as the status gets updated (much like a staging light at a drag-strip).

For instance, the top-most icon is the green check / red exclamation. If it succeeds, the next icon below the green check would be the >| (Message Received), and the next below that would be the eye (Message Read).

In an alternative representation, the single current status icon's position stays. However, as the status changes, that single icon gets updated/replaced with the proper status icon. This approach gives less visual clutter and would be consistent with the current implementation.

Attached is a (poor) mock-up of what the staging light method might look like.

I'm not terribly partial to the staging light, but it does have a consistency and sense about it I do like. I think someone with a better aesthetic could take the concept and make it fit the UI better than my simple mock-up can.
Actually, I think we have it in v2.0 since bug 1010093.

Can you look at the mockup in attachment 8423793 [details] and tell me if this provides the functionality you want? The "read" status is shown by a small stylized eye.
(Reporter)

Comment 2

4 years ago
That is exactly what I was looking for for the "Read" status, Julien.

Do you know if a "Received/Delivered" status icon could also be created and added along the same lines?

I can try my hand at making a few icons in SVG/PNG if you'd like.

I'm using 2014-07-31 v2.1 compile but the read status icon doesn't appear to be working yet in master.
There is also a "delivered" status icon (I think it's there since v1.4), but we don't display it when we got a "read" status (because obviously if it's "read" it's also "delivered" :) ).

On the attachment above, you can see the green tick at the bottom.

I'm duping then :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1010093
You need to log in before you can comment on or make changes to this bug.