Missing "Submit a crash report" button from OpenH264 crash reporting notification [Windows only]

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: adalucinet, Assigned: gfritzsche)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Windows 7
Points:
3

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Reproducible on:
the latest Aurora (BuildID: 20140731004002): 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
the latest Nightly (BuildID: 20140731030206): 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

Steps to reproduce:
1. Launch Firefox and wait for OpenH264 plugin to install 
2. Go to http://mozilla.github.io/webrtc-landing/pc_test.html
3. Start test with "require h264 video" checkbox marked
4. Kill the plugin-container.exe process


Expected results: "Submit a crash report" button is available in the OpenH264 crash reporting notification.

Actual results: "Submit a crash report" button is not available in the OpenH264 crash reporting notification.

Notes:
1. On Mac OS X 10.9.4 and Ubuntu 13.04 64bit, the button is shown.
2. Not a regression - reproducible with Nightly 2014-07-30, when OpenH264 crash reporting notification is first shown (bug 1043531)
3. Logs: https://pastebin.mozilla.org/5746547
Alexandra -- If you find any more regressions or bugs against OpenH264, can you mark them as blocking Bug 948160 (the main tracking bug for OpenH264)?  Thanks.
Blocks: 948160
Flags: needinfo?(alexandra.lucinet)
Whiteboard: [openh264-uplift]
(Reporter)

Comment 2

4 years ago
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #1)
> Alexandra -- If you find any more regressions or bugs against OpenH264, can
> you mark them as blocking Bug 948160 (the main tracking bug for OpenH264)? 
> Thanks.

Sure thing! Thanks for the heads-up!
Flags: needinfo?(alexandra.lucinet)
(Assignee)

Comment 3

4 years ago
You probably won't see a crashreporter for plugins like Flash either due to how you kill the process.

Jesup, could we put a crashing version of the OpenH264 plugin up somewhere for QA purposes around crash reporting?
Flags: needinfo?(rjesup)
(Assignee)

Comment 4

4 years ago
Nevermind... Alexandra, per bug 1044408 we now have an easy way: every time you flip the pref "media.gmp.plugin.crash" to true it crashes with a signature like bp-f53d6fec-9312-4d1f-9548-804512140804:
>  mozalloc_abort(char const*) | abort | mozilla::gmp::GMPChild::RecvCrashPluginNow()

... the signature may differ a bit across platforms. This would be the best way to test GMP crashes going forward.

Can you re-check with that?
Flags: needinfo?(rjesup) → needinfo?(alexandra.lucinet)
(Reporter)

Comment 5

4 years ago
(In reply to Georg Fritzsche [:gfritzsche] from comment #4)
> Nevermind... Alexandra, per bug 1044408 we now have an easy way: every time
> you flip the pref "media.gmp.plugin.crash" to true it crashes with a
> signature like bp-f53d6fec-9312-4d1f-9548-804512140804:
> >  mozalloc_abort(char const*) | abort | mozilla::gmp::GMPChild::RecvCrashPluginNow()
> 
> ... the signature may differ a bit across platforms. This would be the best
> way to test GMP crashes going forward.
> 
> Can you re-check with that?

I've verified with latest Nightly on Windows 7 x64, but after I set media.gmp.plugin.crash to true, the crash reporter notification is displayed and that's all: no submit report button, no crash in about:crashes. Am I missing something here?
Flags: needinfo?(alexandra.lucinet) → needinfo?(georg.fritzsche)
(Assignee)

Comment 6

4 years ago
Ok, i'll have to investigate this then.
Flags: needinfo?(georg.fritzsche)
(Assignee)

Updated

4 years ago
Flags: firefox-backlog+
(Assignee)

Updated

4 years ago
Assignee: nobody → georg.fritzsche
(Assignee)

Updated

4 years ago
Points: --- → 3
QA Whiteboard: [qa+]
Note: I looked, and I just switched on inbound from abort() to MOZ_CRASH() - that was a nit from ted I forgot to include in the checkin
(Assignee)

Comment 8

4 years ago
I checked on a Windows mozilla-inbound build and it seems fine - please recheck using the crash pref when rev 542da58f9e14 from bug 1044408, comment 21 reaches Nightly.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Flags: firefox-backlog+
(Reporter)

Comment 9

4 years ago
I also confirm that this issue is fixed with latest Nightly (Build ID: 20140805030300) on Windows 7 x64.
QA Whiteboard: [qa+] → [qa!]

Updated

4 years ago
Whiteboard: [openh264-uplift]
You need to log in before you can comment on or make changes to this bug.