entering square brackets in location bar crashes [@ nsDefaultURIFixup::KeywordURIFixup(nsACString_internal const&, nsDefaultURIFixupInfo*, nsIInputStream**) ]

VERIFIED FIXED in Firefox 33

Status

()

Firefox
Address Bar
--
critical
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Yohann Jardin, Assigned: Gijs)

Tracking

({crash, regression})

34 Branch
Firefox 34
crash, regression
Points:
2
Bug Flags:
firefox-backlog +
in-testsuite +

Firefox Tracking Flags

(firefox33 verified, firefox34 verified)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140731030206

Steps to reproduce:

Write [] in the Location bar and push Enter.


Actual results:

Firefox crash


Expected results:

A search on " [] " should have been launched.


Tried [, ] and {}, these 3 work fine.

Through mozregression :
Last good revision: 9b764e12796d
First bad revision: b97d42484365
(Reporter)

Updated

4 years ago
Component: Untriaged → Location Bar
Confirmed against Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140801093819 CSet: 31f7e7f7d69b

bp-a5812d81-efb0-42b2-bf74-b85052140801
Blocks: 693808
Status: UNCONFIRMED → NEW
Crash Signature: [@ nsDefaultURIFixup::KeywordURIFixup(nsACString_internal const&, nsDefaultURIFixupInfo*, nsIInputStream**) ]
Ever confirmed: true
Keywords: regression
Summary: Square brackets in location bar → entering square brackets in location bar crashes [@ nsDefaultURIFixup::KeywordURIFixup(nsACString_internal const&, nsDefaultURIFixupInfo*, nsIInputStream**) ]

Updated

4 years ago
Flags: firefox-backlog+
(Assignee)

Comment 2

4 years ago
Gavin, looks like more things that need to be fixed as soon as possible. :-\
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 34.2
Points: --- → 2
Flags: needinfo?(gavin.sharp)
(Assignee)

Updated

4 years ago
Severity: normal → critical
Keywords: crash
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Comment 3

4 years ago
Actually, I have a patch already...
Iteration: 34.2 → 34.1
(Assignee)

Comment 4

4 years ago
Created attachment 8467066 [details] [diff] [review]
fix crash in nsIURIFixup,
Attachment #8467066 - Flags: review?(benjamin)
(Assignee)

Comment 5

4 years ago
(this patch is based on top of the one for bug 1042519, but should not be hard to unbitrot if that somehow gets held up (which I believe to be unlikely, but hey))
Attachment #8467066 - Flags: review?(benjamin) → review+
Flags: needinfo?(gavin.sharp)
Added to Iteration 34.1
QA Whiteboard: [qa?]
(Assignee)

Updated

4 years ago
QA Whiteboard: [qa?] → [qa+]

Updated

4 years ago
Iteration: 34.1 → 34.2
(Assignee)

Comment 7

4 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/153960bf7476
Whiteboard: [fixed-in-fx-team]
QA Contact: alexandra.lucinet

Comment 8

4 years ago
https://hg.mozilla.org/mozilla-central/rev/153960bf7476
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 34
QA Contact: alexandra.lucinet → camelia.badau
Verified fixed on Windows 7 64bit, Windows 7 32bit, Windows 8.1, Ubuntu 13.10 32bit and Mac OSX 10.8.5 using latest Nightly 34.0a1 (buildID: 20140806030201).
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa+] → [qa!]
(Assignee)

Comment 10

4 years ago
Comment on attachment 8467066 [details] [diff] [review]
fix crash in nsIURIFixup,

Approval Request Comment
[Feature/regressing bug #]: 693808
[User impact if declined]: crash with certain location bar input
[Describe test coverage new/current, TBPL]: automated coverage, as well as manual verification
[Risks and why]: none
[String/UUID change made/needed]: none
Attachment #8467066 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

4 years ago
status-firefox33: --- → affected
status-firefox34: --- → verified
Attachment #8467066 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: in-testsuite+
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.4 using latest Aurora 33.0a2 (buildID: 20140820004001).
status-firefox33: fixed → verified
You need to log in before you can comment on or make changes to this bug.