save dialog doesn't open symlinks to dirs

VERIFIED DUPLICATE of bug 92329

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 92329
16 years ago
13 years ago

People

(Reporter: Frank Wales, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101202

The save dialog (Save As..., or popped-up for downloading) correctly displays
symlinks to directories with a folder icon.  However, double-clicking on the
symlink name fails to descend into it.

Reproducible: Always
Steps to Reproduce:
Showing this is easy:  at a prompt, do
  cd /tmp
  mkdir foo
  ln -s foo bar
Now, try to save any page (or any mail message, for that matter) into /tmp/bar
by navigating there within the save dialog.



Actual Results:  No amount of clicking on 'bar' in the listing of the content of
'/tmp' will make progress.

Expected Results:  Clicking on 'bar' in the listing of /tmp should work just the
same as clicking on 'foo'.  After all, this is how the file system works, and
this is what the displayed folder icon leads the user to expect.

I'm sure this used to work fine until a release or two ago.  (Plus, I suspect
it's a fairly simple oversight in the code -- I don't have an up-to-date copy of
the source to check this hunch with, though.)

*** This bug has been marked as a duplicate of 92329 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.