Closed Bug 1047719 Opened 7 years ago Closed 7 years ago

Deal with absence of 'removed-files' from Contents/MacOS with new v2 signatures

Categories

(Toolkit :: Application Update, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1059567

People

(Reporter: spohl, Assigned: robert.strong.bugs)

References

Details

As part of bug 1047584 we will be removing the 'removed-files' file from Contents/MacOS. We will need to make sure that we can still generate MARs etc without it. If it is still required, we may be able to move it to Contents/Resources. However, it will need to exist there before the .app bundle is signed.
I think there might be a case where removed-files is used from a packaged build vs. a local build during during mar file generation. It should be somewhat trivial to move this to Contents/Resources if we need this file.
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Blocks: 1046906
No longer blocks: 1047584
Group: mozilla-employee-confidential
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1059567
You need to log in before you can comment on or make changes to this bug.