Closed Bug 1047767 Opened 7 years ago Closed 7 years ago

Intermittent TEST-UNEXPECTED-ERROR | test_filter_number.js | TimeoutException: TimeoutException: Connection timed out Return code: 10

Categories

(Firefox OS Graveyard :: General, defect)

x86
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1048098

People

(Reporter: ewong, Unassigned)

References

Details

[b2g_emulator_vm mozilla-central opt test marionette-webapi]

From:
https://tbpl.mozilla.org/?onlyunstarred=1&rev=8970589d6505

Got:
16:40:10     INFO -  08-01 19:34:08.112 I/Gecko   (   44): 1406936048112	Marionette	INFO	sendToClient: {"from":"0","value":{"passed":58,"failed":0,"failures":[]}}, {41726f00-e0c5-4bd2-8819-f67cd6988657}, {41726f00-e0c5-4bd2-8819-f67cd6988657}
16:40:10     INFO -  B2G is still running but Marionette can't respond due to either a Gecko, Gaia or Marionette error. Above, the 5 most recent errors are listed. Check logcat for all errors if these errors are not the cause of the failure.
16:40:10    ERROR -  TEST-UNEXPECTED-ERROR | test_filter_number.js | TimeoutException: TimeoutException: Connection timed out
16:40:10     INFO -  Traceback (most recent call last):
16:40:10     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 171, in run
16:40:10     INFO -      testMethod()
16:40:10     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 524, in runTest
16:40:10     INFO -      self.marionette.execute_script("log('TEST-END: %s');" % self.jsFile.replace('\\', '\\\\'))
16:40:10     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 1199, in execute_script
16:40:10     INFO -      filename=os.path.basename(frame[0]))
16:40:10     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/decorators.py", line 35, in _
16:40:10     INFO -      return func(*args, **kwargs)
16:40:10     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 617, in _send_message
16:40:10     INFO -      "Connection timed out", status=errors.ErrorCodes.TIMEOUT)
Apparently I missed the Gecko errors above those lines:

INFO -  08-01 19:33:57.383 I/Gecko   (   44): 1406936037386	Marionette	INFO	sendToClient: {"from":"0","value":{"passed":38,"failed":0,"failures":[]}}, {fbf655da-d096-460c-b06e-fce31f37094f}, {fbf655da-d096-460c-b06e-fce31f37094f}
16:40:10     INFO -  08-01 19:33:57.413 I/Gecko   (   44): 1406936037418	Marionette	DEBUG	Got request: execute, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"34.0a1","takesScreenshot":true,"appBuildId":"20140801070614","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"34.0a1","device":"qemu","b2g":true,"nativeEvents":false,"platformVersion":"34.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"executeScript","parameters":{"scriptTimeout":null,"specialPowers":false,"script":"log('TEST-END: /builds/slave/test/build/tests/marionette/tests/dom/mobilemessage/tests/marionette/test_filter_date.js');","newSandbox":true,"args":[],"filename":"marionette_test.py","line":524}}, id: {67893248-f56b-4ae4-8f9f-25ef6c11778e}
16:40:10     INFO -  08-01 19:33:57.453 I/Gecko   (   44): MARIONETTE LOG: INFO: TEST-END: /builds/slave/test/build/tests/marionette/tests/dom/mobilemessage/tests/marionette/test_filter_date.js
16:40:10     INFO -  08-01 19:33:57.463 I/Gecko   (   44): 1406936037471	Marionette	INFO	sendToClient: {"from":"0","value":null}, {67893248-f56b-4ae4-8f9f-25ef6c11778e}, {67893248-f56b-4ae4-8f9f-25ef6c11778e}
16:40:10     INFO -  08-01 19:33:57.503 I/Gecko   (   44): 1406936037509	Marionette	DEBUG	Got request: setTestName, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"34.0a1","takesScreenshot":true,"appBuildId":"20140801070614","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"34.0a1","device":"qemu","b2g":true,"nativeEvents":false,"platformVersion":"34.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"setTestName","parameters":{"value":null}}, id: {bf487d5b-9a1c-4ba8-9a06-bca4cf90fbdb}
16:40:10     INFO -  08-01 19:33:57.513 I/Gecko   (   44): 1406936037515	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {bf487d5b-9a1c-4ba8-9a06-bca4cf90fbdb}, {bf487d5b-9a1c-4ba8-9a06-bca4cf90fbdb}
16:40:10     INFO -  08-01 19:33:57.552 I/Gecko   (   44): 1406936037553	Marionette	INFO	sendToClient: {"from":"0","value":[["INFO","TEST-START: /builds/slave/test/build/tests/marionette/tests/dom/mobilemessage/tests/marionette/test_filter_date.js","Fri Aug 01 2014 19:33:49 GMT-0400 (EDT)"],["INFO","navigator.mozMobileMessage is instance of function MozMobileMessageManager() {\n    [native code]\n}","Fri Aug 01 2014 19:33:50 GMT-0400 (EDT)"],["INFO","startTime: 1406936031448, endTime: 1406936034092","Fri Aug 01 2014 19:33:54 GMT-0400 (EDT)"],["INFO","Testing [startTime, )","Fri Aug 01 2014 19:33:54 GMT-0400 (EDT)"],["INFO","  Found 10 messages, expected 10","Fri Aug 01 2014 19:33:54 GMT-0400 (EDT)"],["INFO","Testing (, endTime]","Fri Aug 01 2014 19:33:54 GMT-0400 (EDT)"],["INFO","  Found 10 messages, expected 10","Fri Aug 01 2014 19:33:55 GMT-0400 (EDT)"],["INFO","Testing [startTime, endTime]","Fri Aug 01 2014 19:33:55 GMT-0400 (EDT)"],["INFO","  Found 10 messages, expected 10","Fri Aug 01 2014 19:33:55 GMT-0400 (EDT)"],["INFO","Testing [, startTime)","Fri Aug 01 20
16:40:10     INFO -  08-01 19:33:57.632 I/Gecko   (   44): 1406936037632	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {885b98a6-f6f9-4e9d-b65a-a1a11df7b32d}, {885b98a6-f6f9-4e9d-b65a-a1a11df7b32d}
16:40:10     INFO -  08-01 19:33:59.052 I/Gecko   (   44): 1406936039055	Marionette	DEBUG	accepted connection on 127.0.0.1:54897
16:40:10     INFO -  08-01 19:33:59.182 I/Gecko   (   44): 1406936039189	Marionette	INFO	could not load listener into content for page: chrome://b2g/content/shell.html
16:40:10     INFO -  08-01 19:33:59.203 I/Gecko   (   44): 1406936039205	Marionette	INFO	sendToClient: {"from":"0","value":{"browserName":"B2G","browserVersion":"34.0a1","platformName":"ANDROID","platformVersion":"34.0a1","handlesAlerts":false,"nativeEvents":false,"rotatable":true,"secureSsl":false,"takesElementScreenshot":true,"takesScreenshot":true,"platform":"ANDROID","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","appBuildId":"20140801070614","device":"qemu","version":"34.0a1","b2g":true}}, {728ab257-6b89-4040-9391-6623565c315a}, {728ab257-6b89-4040-9391-6623565c315a}
16:40:10     INFO -  08-01 19:33:59.263 I/Gecko   (   44): 1406936039260	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {4c5f3808-0dfd-4016-bd20-350309295750}, {4c5f3808-0dfd-4016-bd20-350309295750}
16:40:10     INFO -  08-01 19:33:59.293 I/Gecko   (   44): 1406936039299	Marionette	DEBUG	Got request: setTestName, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"34.0a1","takesScreenshot":true,"appBuildId":"20140801070614","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"34.0a1","device":"qemu","b2g":true,"nativeEvents":false,"platformVersion":"34.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"setTestName","parameters":{"value":"test_filter_number.js"}}, id: {91fa16fd-a83f-4044-8ae5-e35ba0db1a96}
16:40:10     INFO -  08-01 19:33:59.303 I/Gecko   (   44): 1406936039305	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {91fa16fd-a83f-4044-8ae5-e35ba0db1a96}, {91fa16fd-a83f-4044-8ae5-e35ba0db1a96}
16:40:10     INFO -  08-01 19:33:59.343 I/Gecko   (   44): 1406936039348	Marionette	DEBUG	Got request: execute, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"34.0a1","takesScreenshot":true,"appBuildId":"20140801070614","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"34.0a1","device":"qemu","b2g":true,"nativeEvents":false,"platformVersion":"34.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"executeScript","parameters":{"scriptTimeout":null,"specialPowers":false,"script":"log('TEST-START: /builds/slave/test/build/tests/marionette/tests/dom/mobilemessage/tests/marionette/test_filter_number.js');","newSandbox":true,"args":[],"filename":"marionette_test.py","line":409}}, id: {80866f85-7b7c-4464-b27c-d0d516073711}
16:40:10     INFO -  08-01 19:33:59.383 I/Gecko   (   44): MARIONETTE LOG: INFO: TEST-START: /builds/slave/test/build/tests/marionette/tests/dom/mobilemessage/tests/marionette/test_filter_number.js
16:40:10     INFO -  08-01 19:33:59.393 I/Gecko   (   44): 1406936039394	Marionette	INFO	sendToClient: {"from":"0","value":null}, {80866f85-7b7c-4464-b27c-d0d516073711}, {80866f85-7b7c-4464-b27c-d0d516073711}
16:40:10     INFO -  08-01 19:33:59.672 E/GeckoConsole(   44): [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<html>test%20page</html>" line: 0}]
16:40:10     INFO -  08-01 19:33:59.972 I/Gecko   (   44): 1406936039973	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {f2e2fbdf-4eee-4df5-bdb5-33408074d0c5}, {f2e2fbdf-4eee-4df5-bdb5-33408074d0c5}
16:40:10     INFO -  08-01 19:34:00.042 I/Gecko   (   44): 1406936040043	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {638c7769-fa4f-4ca8-8e88-be5acf19f1b9}, {638c7769-fa4f-4ca8-8e88-be5acf19f1b9}
16:40:10     INFO -  08-01 19:34:00.362 I/Gecko   (   44): MARIONETTE TEST RESULT:TEST-PASS | test_filter_number.js | permissions pushed: [{"type":"sms","allow":1,"context":{"location":{"href":"data:text/html,<html>test%20page</html>","origin":"null","protocol":"data:","username":"","password":"","host":"","hostname":"","port":"","pathname":"","search":"","hash":""}}}] - true was true, expected true
16:40:10     INFO -  08-01 19:34:00.373 I/Gecko   (   44): MARIONETTE LOG: INFO: navigator.mozMobileMessage is instance of function MozMobileMessageManager() {
16:40:10     INFO -  08-01 19:34:00.373 I/Gecko   (   44):     [native code]
16:40:10     INFO -  08-01 19:34:00.373 I/Gecko   (   44): }
16:40:10     INFO -  08-01 19:34:00.383 E/GeckoConsole(   44): [JavaScript Error: "Content Security Policy: The page's settings blocked the loading of a resource at self ("script-src app://system.gaiamobile.org")." {file: "chrome://specialpowers/content/specialpowersAPI.js" line: 732 column: 0 source: "call to eval() or related function blocked by CSP"}]
16:40:10     INFO -  08-01 19:34:00.473 I/Gecko   (   44): MARIONETTE TEST RESULT:TEST-PASS | test_filter_number.js | no message to be deleted - true was true, expected true
16:40:10     INFO -  08-01 19:34:00.692 I/Gecko   (   44): MARIONETTE TEST RESULT:TEST-PASS | test_filter_number.js | aRequest is instanceof function DOMRequest() {
16:40:10     INFO -  08-01 19:34:00.692 I/Gecko   (   44):     [native code]
16:40:10     INFO -  08-01 19:34:00.692 I/Gecko   (   44): } - true was true, expected true
I saw the same error meessage "[JavaScript Error: "Content Security Policy: ..." in bug 1048098 and have already patch there.
Status: NEW → RESOLVED
Closed: 7 years ago
Depends on: 1048098
Resolution: --- → DUPLICATE
Duplicate of bug: 1048098
You need to log in before you can comment on or make changes to this bug.