Back button goes to incorrect page.

VERIFIED DUPLICATE of bug 103978

Status

()

VERIFIED DUPLICATE of bug 103978
18 years ago
11 years ago

People

(Reporter: mark, Assigned: radha)

Tracking

Trunk
mozilla0.9.6
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

This was observed after using the currently running process for a while to
browse other stuff so who knows if the corruption happend a while ago, but here
is what I saw:


  (1) Went to view how the home-page of the co-location company I use
      looks under Mozilla (http://www.dialtoneinternet.com/)

  (2) That needed Shockwave Flash, so I shut down Mozilla 
      and re-started the process.

  (3) Check my Co-lo's page then check news on Slashdot
      (http://slashdot.org/)

  (4) See what is happening in the world on CNN (http://cnn.com/)

  (5) Clicked link to Taliban story on CNN. Read story and clicked
      back.

After step #5, Mozilla took me to http://www.dialtone.com and the Back button
was disabled as if there was no more history. 

Note: I also had several other browser windows open to various sites
(http://www.weatherundergroun.com [sends cookies]) and my open-source website
(http://www.conman.org/ - pretty vanilla)

Reproducible: Didn't try
Steps to Reproduce:
1. Start browser
2. Goto URL.
3. Enter different URL than in #2 in location bar. 
4. Click link off URL from step #3.
5. Click back. Wrong URL obtained from History.


Actual Results:  The browser disabled the back button (as if there was no
previous history -- and there was) and took me to the wrong spot (arguably the
first URL I typed into the current session).

Expected Results:  Taken me to http://cnn.com since I had previously clicked a
link off that page when I had invoked the Back button.
THis is probably dupe of another bug I have scheduled for 0.9.6. But would like
to use the steps to reproduce lined out in this bug.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → mozilla0.9.6
This is dupe of 103978. Also the problem described here, very similar to 103978
is not reproducible in today's trunk builds. 

*** This bug has been marked as a duplicate of 103978 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
v
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.