[Flatfish][Homescreen] Returning home (landscape) from portrait app causes wrong width/height

RESOLVED DUPLICATE of bug 1004329

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1004329
4 years ago
4 years ago

People

(Reporter: Raniere Silva, Assigned: yifan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8466700 [details]
screenshot of "small" homescreen

*** Create as duplicate of Bug 1004329 ***

Steps to Reproduce:

1. On flatfish device open one app that support portrait mode (e.g web browser).
2. Change the orientation mode to portrait.
3. Use home gesture to return to Homescreen.

Actual Results:

Homescreen with wrong width/height (see attachment).
	 
Expected Results:

Homescreen with correct width/height.

Aditional Information:

- OS version
  2.1.0.0-prerelease
- Firmware revision
  flatfish_20140703-2323
- Hardware revision
  flatfish
- Platform version
  34.0a1
- B2G
  commit b91a268d3415fd5eec2fab45d3072067e8c0b33d
  Date:   Wed Jun 18 13:25:13 2014 -0700
- Gaia
  commit 445cd4844a35213da74057f4629ee269a29229a0
  Date:   Sat Aug 2 14:20:40 2014 +0200
(Reporter)

Updated

4 years ago
Blocks: 1004329

Comment 1

4 years ago
Confirming this on the vendor build from 20140801.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This may be a duplicate from bug 1004329, :yifan is currently working on it and has a patch:
attachment 8460129 [details] [review]

The patch is pending review but I think it may help on this bug also.
(Assignee)

Comment 3

4 years ago
The fix is landed. While I couldn't reproduce these 2 bugs now, bug 1004329 still seems to happen on YF(Yang)'s device. Any confirmation is welcome.
(Assignee)

Updated

4 years ago
Assignee: nobody → yliao
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1004329
You need to log in before you can comment on or make changes to this bug.