Event listener popup shows jQuery event binding

RESOLVED DUPLICATE of bug 1044932

Status

RESOLVED DUPLICATE of bug 1044932
4 years ago
3 months ago

People

(Reporter: mkelly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
If you bind an event listener to an element via a library like jQuery and inspect the bound listener with the event listener popup in the Inspector, you get taken to the jQuery listener that defers to your own listener.

This is expected given that jQuery's listener is the actual thing that's listening, but it would be really nice if we could somehow show the listener that jQuery calls.

Perhaps have the popup ignore listeners that are in a blackboxed source file and just list whatever calls emit from those listeners?
(Reporter)

Comment 1

4 years ago
Example JSFiddle: http://jsfiddle.net/M9uh2/
Flags: firefox-backlog?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1044932
Flags: firefox-backlog?

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.