translate3d(0,0,0) hides applet behind modal

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: bigj95t, Unassigned)

Tracking

(Blocks: 1 bug)

31 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8467067 [details]
Transform rule disabled (left) and transform rule enabled (right)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

1. Open http://tomcat7-yadav3dplm.rhcloud.com/TestApplet/Test.html
2. Allow Java to be run


Actual results:

Bootstrap uses `transform: translate3d(0,0,0)` on modals to fix repaints when the user is scrolling. This causes applets that are child elements of modals to be hidden behind the modal. (When the `transform` rule is temporarily disabled using Page Inspector, the applet appears on top of the modal.)

The applet (which has a rectangular background that overlaps the modal's rounded top left corner when visible) doesn't seem to be visible underneath the modal or its backdrop either.


Expected results:

The example page above contains a modal which in turn contains an applet that should display "----------Content from Applet----------". The applet should be successfully displayed on top of the modal. This works fine in Chrome 36.0.1985.125 and IE11.

Original issue at Bootstrap: https://github.com/twbs/bootstrap/issues/14124
(Reporter)

Updated

4 years ago

Comment 1

4 years ago
It also works fine in Firefox on Mac OS X, so it appears to be Windows-specific.

Comment 2

4 years ago
It works in previous versions of Firefox on Win 7:
Regression:
good=2012-02-29
bad=2012-03-01
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=30b4f99a137c&tochange=1c3b291d0830

After 2012-03-01, I got a Java error about "TestApplletClass.class".
Surely a side-effect of bug 406541.
Component: Untriaged → Plug-ins
Flags: needinfo?(jschoenick)
Keywords: regressionwindow-wanted
Product: Firefox → Core
(In reply to Loic from comment #2)
> It works in previous versions of Firefox on Win 7:
> Regression:
> good=2012-02-29
> bad=2012-03-01
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=30b4f99a137c&tochange=1c3b291d0830
> 
> After 2012-03-01, I got a Java error about "TestApplletClass.class".
> Surely a side-effect of bug 406541.

Bug 406541 was backed out because it broke loading java in some instances, which is probably what you're seeing in this range
Flags: needinfo?(jschoenick)
oh and there was a typo in the backout message, so it is hard to find:
https://hg.mozilla.org/mozilla-central/rev/47f814827db6

So 2012-07-03 is the backout that should un-break the testcase, if someone wants to find a closer regression range there.

FWIW, windowed-mode plugins have always been incompatible with CSS transforms -- I suspect some layout optimization was making this transform a no-op, and some layerization change broke that.

Comment 5

4 years ago
Any chance of getting the Status updated to NEW and also of someone having another go at finding the regression window?

Comment 6

4 years ago
I wasn't able to find a 2nd regression range, because after the backout of bug 406541, the Java applet is still broken displaying a blank window. Maybe the regression appeared between 2012-03-01 and 2012-07-03.

Updated

4 years ago
Flags: needinfo?(twalker)
Flags: needinfo?(anthony.s.hughes)
I'll take this
Flags: needinfo?(anthony.s.hughes)
Is there another test case. The one is original comment isn't being served.  

Need info me again if another test case is available. Then I try the regression range.
Flags: needinfo?(twalker)

Comment 9

4 years ago
Created attachment 8562293 [details]
Testcase HTML

Comment 10

4 years ago
Created attachment 8562295 [details]
Java .class file for testcase

The example is still online as far as I can tell.

It's literally just an <applet> inside the <div class="modal-content"> of a Bootstrap v3.2.0 modal (http://getbootstrap.com/javascript/#modals-examples ).

Uploaded a slightly cleaned-up copy of the example for good measure.

Updated

4 years ago
Flags: needinfo?(twalker)
I can't get the attachment installed/running.  

Which demo at http://getbootstrap.com/javascript/#modals-examples?  

Clear steps to reproduce would be helpful.
Flags: needinfo?(twalker)

Comment 12

4 years ago
> Which demo at http://getbootstrap.com/javascript/#modals-examples?  

None of those. The bug only occurs on when there's a Java applet in the modal.

The original example ( http://tomcat7-yadav3dplm.rhcloud.com/TestApplet/Test.html ) is still online and demonstrates the problem. It's possible that rhcloud might spin down the app when nobody visits it for a while; if that happens, just refresh a few times in a 5 minute period and it should spin back up and load.

Comment 13

4 years ago
See comment 0 for repro steps.
Flags: needinfo?(twalker)
I'm no longer working on DOM related bugs.
Flags: needinfo?(twalker)

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Is this still reproducible?
Flags: needinfo?(bigj95t)

Comment 16

3 years ago
Yes. Via https://github.com/supergibbs in Bootstrap's Slack room:

> supergibbs [5:13 PM]
> bug seems to exist both in the latest public version (41.0.1) and the dev version (43.0a2 (2015-09-30))
Flags: needinfo?(bigj95t)

Comment 17

3 years ago
We aren't going to fix this issue. Windowed-mode plugins such as Java don't participate in the CSS rendering order very well, and since they are a dying legacy technology we've chosen not to spend time fixing this.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Keywords: regressionwindow-wanted

Updated

2 years ago
Blocks: 1230801
You need to log in before you can comment on or make changes to this bug.