Closed Bug 1048518 Opened 8 years ago Closed 5 years ago

"this._observers is undefined" on merging buddies

Categories

(Instantbird :: Contacts window, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: aleth, Assigned: aleth)

Details

Attachments

(1 file)

Timestamp: 04/08/2014 22:52:52
Error: this._observers is undefined
Source File: file:/.../components/imContacts.js
Line: 851

Timestamp: 04/08/2014 22:52:52
Error: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "this._observers is undefined" {file: "file:///.../components/imContacts.js" line: 851}]'[JavaScript Error: "this._observers is undefined" {file: "file://.../components/imContacts.js" line: 851}]' when calling method: [imIContact::addObserver]
Source File: chrome://chat/content/imtooltip.xml
Line: 99
The only way I can see this happening is from a tooltip over a contact that has just been removed due to the merge.
Hard to reproduce, but I think this should fix it.
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Attachment #8467359 - Flags: review?(florian)
Attachment #8467359 - Flags: review?(florian)
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.