dom/media/test/crashtests/0-timescale.html is perma-fail on Android

RESOLVED FIXED

Status

()

Core
Audio/Video: Playback
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: RyanVM, Assigned: esawin)

Tracking

Trunk
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
In bug 1048624, I'm trying to re-enable the content/media crashtests on Android (which are currently all being skipped). In the course of that testing, I found that 0-timescale.html currently perma-fails per the log below. I plan to skip the test for now while the cause is investigated and a fix landed.

https://tbpl.mozilla.org/php/getParsedLog.php?id=45177140&tree=Try

Android 4.0 Panda try opt test crashtest on 2014-08-04 06:54:26 PDT for push 669303742d9e
slave: panda-0742

07:06:42     INFO -  REFTEST TEST-START | http://10.26.135.20:30742/tests/content/media/test/crashtests/0-timescale.html
07:06:42     INFO -  REFTEST TEST-LOAD | http://10.26.135.20:30742/tests/content/media/test/crashtests/0-timescale.html | 231 / 2704 (8%)
07:11:43     INFO -  REFTEST TEST-UNEXPECTED-FAIL | http://10.26.135.20:30742/tests/content/media/test/crashtests/0-timescale.html | load failed: timed out waiting for reftest-wait to be removed
07:11:43     INFO -  REFTEST INFO | Saved log: START http://10.26.135.20:30742/tests/content/media/test/crashtests/0-timescale.html
07:11:43     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
07:11:43     INFO -  REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
07:11:43     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
07:11:43     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
07:11:43     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
07:11:43     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
07:11:43     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
07:11:43     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.26.135.20:30742/tests/content/media/test/crashtests/0-timescale.html
07:11:43     INFO -  REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
07:11:43     INFO -  REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 672
07:11:43     INFO -  REFTEST INFO | Saved log: Updating canvas for invalidation
07:11:43     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
07:11:43     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
07:11:43     INFO -  REFTEST INFO | Loading a blank page
07:11:43     INFO -  REFTEST TEST-END | http://10.26.135.20:30742/tests/content/media/test/crashtests/0-timescale.html
(Reporter)

Comment 1

3 years ago
It's worth noting that this is already being skipped on B2G as well.
This test should be disabled for Android because the root cause is the libstagefright library provided by the platform.
(Reporter)

Comment 3

3 years ago
Test disabled on Android.
https://hg.mozilla.org/integration/mozilla-inbound/rev/446650efe0b6
Assignee: nobody → ryanvm
Whiteboard: [test disabled on Android][leave open]
(Reporter)

Updated

3 years ago
Assignee: ryanvm → nobody
https://hg.mozilla.org/mozilla-central/rev/446650efe0b6
(Reporter)

Comment 5

2 years ago
Still permafail. Though based on comment 2, I suppose this should just be wontfix?
Summary: content/media/test/crashtests/0-timescale.html is perma-fail on Android → dom/media/test/crashtests/0-timescale.html is perma-fail on Android/B2G
Whiteboard: [test disabled on Android][leave open] → [test disabled on Android/B2G][leave open]
It should be fine on Android 4.1 and later. I'm guessing our infrastructure needs updating.
(Reporter)

Comment 7

2 years ago
It still fails on the Android 4.3 emulator runs. Any suggestions for what needs updating so it can be enabled?
(Reporter)

Comment 8

2 years ago
Android 4.3 run:
https://treeherder.mozilla.org/logviewer.html#?job_id=10121053&repo=try
James - this test should be testing the same path on 4.3 Android as it is on desktop. Want to take a peek?
Flags: needinfo?(snorp)
Component: Audio/Video → Audio/Video: Playback
Assignee: nobody → esawin
Flags: needinfo?(snorp)
(Assignee)

Comment 10

2 years ago
Created attachment 8692936 [details] [diff] [review]
0001-Bug-1048628-1.1-Enabled-0-timescale-test-on-Android-.patch
Attachment #8692936 - Flags: review?(snorp)
(Assignee)

Comment 11

2 years ago
Created attachment 8692937 [details] [diff] [review]
0002-Bug-1048628-2.1-Enabled-autoplay-in-0-timescale-test.patch

On Fennec, we don't try to parse metadata on page load, we only do so with autoplay enabled or on explicit request.
Attachment #8692937 - Flags: review?(snorp)
(Assignee)

Comment 12

2 years ago
Looks good on Try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=55ba760644af
(Reporter)

Comment 13

2 years ago
Comment on attachment 8692936 [details] [diff] [review]
0001-Bug-1048628-1.1-Enabled-0-timescale-test-on-Android-.patch

Review of attachment 8692936 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/media/test/crashtests/crashtests.list
@@ +1,1 @@
> +load 0-timescale.html # bug 1048628

Please remove the comment pointing to this bug as well.
(Assignee)

Comment 14

2 years ago
Crashes on B2G ICS emulator: https://treeherder.mozilla.org/logviewer.html#?job_id=14196573&repo=try
(Assignee)

Comment 15

2 years ago
I would propose we only enable it on Android for now and investigate the B2G crash in a separate bug.
Comment on attachment 8692936 [details] [diff] [review]
0001-Bug-1048628-1.1-Enabled-0-timescale-test-on-Android-.patch

Review of attachment 8692936 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, what RyanVM said.
Attachment #8692936 - Flags: review?(snorp) → review+
Attachment #8692937 - Flags: review?(snorp) → review+
(Assignee)

Comment 17

2 years ago
Filed bug to fix this test on B2G: bug 1229166.
Summary: dom/media/test/crashtests/0-timescale.html is perma-fail on Android/B2G → dom/media/test/crashtests/0-timescale.html is perma-fail on Android
(Assignee)

Comment 18

2 years ago
Created attachment 8693794 [details] [diff] [review]
0001-Bug-1048628-1.2-Enabled-0-timescale-test-on-Android-.patch

Enable test on Android, leave disabled on B2G. Carrying over r+.
Attachment #8692936 - Attachment is obsolete: true
Attachment #8693794 - Flags: review+

Comment 19

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/94ac68f353b5
https://hg.mozilla.org/integration/mozilla-inbound/rev/ea4581807191

Comment 20

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/94ac68f353b5
https://hg.mozilla.org/mozilla-central/rev/ea4581807191
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Whiteboard: [test disabled on Android/B2G][leave open]
You need to log in before you can comment on or make changes to this bug.