Closed Bug 1048698 Opened 6 years ago Closed 6 years ago

Add "XPConnect" as a valid value for Exposed

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1073124

People

(Reporter: bzbarsky, Unassigned)

References

Details

It would cause whatever it is to be exposed in things like sandboxes, JSMs, JS components.

Once we do this we can rip out the code in xpc::InitGlobalObject and possibly xpc::GlobalProperties::Define and replace it with codegenned code.

Bobby also suggested "NonDOM" as a name for this value.  Let the great bikeshed begin.
Flags: needinfo?(bzbarsky)
Depends on: 1017988
Forwarding duping to bug 1073124 because there's more context there.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(bzbarsky)
Resolution: --- → DUPLICATE
Duplicate of bug: 1073124
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.