Unable to log in to the Citibank Internet Banking page after the latest update

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
4 years ago
2 years ago

People

(Reporter: Ayan, Unassigned)

Tracking

31 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

386.04 KB, application/x-zip-compressed
Details
(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Tried logging in to the Citibank Internet Login Page

http://www.citibank.co.in and then the Login button



Actual results:

New child page came up. After entering the username password - the password save prompt came up.

Irrespective of whether I chose to save/not save/choose never ask to store password for this page etc, the child page never populates


Expected results:

Using Internet Explorer 11, comes up just fine.

This is happening to two different machines I tried on - a laptop and a desktop - both running Windows 7 - so I know this is not a machine issue

Updated

4 years ago
Component: Untriaged → Password Manager
Product: Firefox → Toolkit

Comment 1

4 years ago
Can you reproduce this issue if you restart with add-ons disabled (entry in the help menu)?
Flags: needinfo?(a_nut_in)
(Reporter)

Comment 2

4 years ago
Created attachment 8467907 [details]
screenshot
Flags: needinfo?(a_nut_in)
(Reporter)

Comment 3

4 years ago
Please see screenshot

1. Disable Add Ons
2. Open Citibank page
3. Click on Login
4. Child Page opens
5. Enter username and password
6. Parent page has password prompt
7. Child page never loads up
(Reporter)

Comment 4

4 years ago
Well more updates:

The child page DOES populate if an "incorrect" username password is entered

So username - TEST
Password - TEST

The child page pops up with:


"Sorry! Your login attempt has failed. This could be because:

1. The User ID/ Card Number you have entered may be incorrect.
2. The Password (IPIN) you have entered may be incorrect.
3. You may already have a User ID for the login card or any linked card(s).

View step by step guide to select new/ retrieve User ID & IPIN"
There's no reason at the moment to believe this is related to the Password Manager.

You should look in the Web Console and Browser Console to see if there are errors showing up. Both can be found in Tools > Web Developer. Clear the consoles, then load the login page and then look for issues. You can attach them as an attachment here if you need help understanding the logs.

Contacting the bank may also be useful to let them know about the issue or finding out if other customers are having the issue with Firefox.
Component: Password Manager → Untriaged
Product: Toolkit → Firefox

Comment 6

4 years ago
I faced the same problem with citibank netbanking. I am using FF31 too. Earlier it was fine. Its very irritating to switch the browser to just visit one website.
(In reply to lovejames from comment #6)
> I faced the same problem with citibank netbanking. I am using FF31 too.
> Earlier it was fine. Its very irritating to switch the browser to just visit
> one website.

Please contact CitiBank to let them know of the issue so then you don't need to switch browsers and it will help others too.
(Reporter)

Comment 8

4 years ago
Output below:

hrzn-prod-iwa-vip.vmware.com : server does not support RFC 5746, see CVE-2009-3555
The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol. authenticate
bugzilla.vmware.com:443 uses an invalid security certificate.

The certificate is only valid for the following names:
  *.eng.vmware.com, eng.vmware.com, bugzilla.eng.vmware.com  

(Error code: ssl_error_bad_cert_domain)

www.online.citibank.co.in : server does not support RFC 5746, see CVE-2009-3555
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://www.online.citibank.co.in/fonts/interstaterom-webfont.woff. This can be fixed by moving the resource to the same domain or enabling CORS. interstaterom-webfont.woff
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://www.online.citibank.co.in/fonts/interstaterom-webfont.ttf. This can be fixed by moving the resource to the same domain or enabling CORS. interstaterom-webfont.ttf
online.citibank.co.in : server does not support RFC 5746, see CVE-2009-3555
gateway.zscaler.net : server does not support RFC 5746, see CVE-2009-3555
Use of getPreventDefault() is deprecated.  Use defaultPrevented instead. jquery-1.8.3.min.js:2
Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help http://xhr.spec.whatwg.org/ rfo_30.js line 1 > eval:1
www.citibank.co.in : server does not support RFC 5746, see CVE-2009-3555
An unbalanced tree was written using document.write() causing data from the network to be reparsed. For more information https://developer.mozilla.org/en/Optimizing_Your_Pages_for_Speculative_Parsing IQPin1.jsp:16
A form was submitted in the windows-1252 encoding which cannot encode all Unicode characters, so user input may get corrupted. To avoid this problem, the page should be changed so that the form is submitted in the UTF-8 encoding either by changing the encoding of the page itself to UTF-8 or by specifying accept-charset=utf-8 on the form element. IQPin1.jsp:457
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://gateway.zscaler.net/auD?origurl=http%3A%2F%2Fwww%2ethecloudlab%2ein%2fwp%2dcontent%2fthemes%2fvantage%2ffontawesome%2ffont%2ffontawesome%2dwebfont%2ewoff%3fv%3d3%2e2%2e1. This can be fixed by moving the resource to the same domain or enabling CORS. auD
downloadable font: download failed (font-family: "FontAwesome" style:normal weight:normal stretch:normal src index:1): bad URI or cross-site access not allowed
source: http://www.thecloudlab.in/wp-content/themes/vantage/fontawesome/font/fontawesome-webfont.woff?v=3.2.1 font-awesome.css
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://gateway.zscaler.net/auD?origurl=http%3A%2F%2Fwww%2ethecloudlab%2ein%2fwp%2dcontent%2fthemes%2fvantage%2ffontawesome%2ffont%2ffontawesome%2dwebfont%2ettf%3fv%3d3%2e2%2e1. This can be fixed by moving the resource to the same domain or enabling CORS. auD
downloadable font: download failed (font-family: "FontAwesome" style:normal weight:normal stretch:normal src index:2): bad URI or cross-site access not allowed
source: http://www.thecloudlab.in/wp-content/themes/vantage/fontawesome/font/fontawesome-webfont.ttf?v=3.2.1 font-awesome.css
Error: Permission denied to access property 'toString' launch.jsp:13
GET http://c1.zedo.com/jsc/c1/fo.js [HTTP/1.1 403 Forbidden 9ms]
GET http://c1.zedo.com/jsc/c1/fo.js [HTTP/1.1 403 Forbidden 20ms]
GET http://c1.zedo.com/jsc/c1/fo.js [HTTP/1.1 403 Forbidden 10ms]
TypeError: datas1 is null ibnlive.in.com:502
GET http://c1.zedo.com/jsc/c1/fos.js [HTTP/1.1 403 Forbidden 10ms]
GET http://c1.zedo.com/jsc/c1/fo.js [HTTP/1.1 403 Forbidden 9ms]
GET http://c1.zedo.com/jsc/c1/fos.js [HTTP/1.1 403 Forbidden 9ms]
GET http://c1.zedo.com/jsc/c1/fos.js [HTTP/1.1 403 Forbidden 10ms]
GET http://c1.zedo.com/jsc/c1/fos.js [HTTP/1.1 403 Forbidden 11ms]
GET http://c1.zedo.com/jsc/c1/fo.js [HTTP/1.1 403 Forbidden 10ms]
TypeError: document.getElementById(...) is null ibncookie_v4-min.js:1
Use of getPreventDefault() is deprecated.  Use defaultPrevented instead. vmf.js:3

Comment 9

4 years ago
@Ayan Is this the first time you visit the Citibank site? If not then possibly there are cookies stored causing the issue. (You have already excluded the add-on possibility) For clearing cookies Go to option->Privacy->remove individual cookies->remove all (Recommended) or you can remove only individual cookies related to the Citibank site.
If it works then let us know.
Flags: needinfo?(a_nut_in)
(Reporter)

Comment 10

4 years ago
I have been logging into my Citibank site for the past 7 years now. This was working last week - prior to the upgrade of FF to 31. Have spoken to Citibank who have referred me back to FF - their point of view - works fine in Chrome/IE/FF 30 downwards - so how is it a Citibank issue?
Flags: needinfo?(a_nut_in)

Comment 11

3 years ago
we experience same behavior after Firefox update:
Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help http://xhr.spec.whatwg.org/

Comment 12

3 years ago
(In reply to Michael from comment #11)
> we experience same behavior after Firefox update:
> Synchronous XMLHttpRequest on the main thread is deprecated because of its
> detrimental effects to the end user's experience. For more help
> http://xhr.spec.whatwg.org/

That is unlikely to be related to what's going on here - "deprecated" means what it says, not that it doesn't work.

Comment 13

2 years ago
Hi, 

Is the issue still reproducing on latest Firefox versions? e.g. Firefox 43 / Nightly 46
Flags: needinfo?(a_nut_in)

Comment 14

2 years ago
Closing as incomplete due to lack of response from the reporter. Fell free to reopen the bug if you can reproduce the issue on a current build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(a_nut_in)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.