"open"ing bookmark in manager opening new window

RESOLVED FIXED in mozilla1.1alpha

Status

SeaMonkey
Bookmarks & History
P2
normal
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Jeremy M. Dolan, Assigned: Blake Ross)

Tracking

Trunk
mozilla1.1alpha
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
double clicking or right clicking and selecting open on a bookmark in the
manager is opening the link in a new window. Not only 4xp, but new window perf
is waaaay too slow to be using that as the default.

Also, 93033 should be fixed along with this one. 93033 is for 'open in new
window' as the alternate, via middle click (UNIX only?) or right click menu.
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
(Reporter)

Comment 2

16 years ago
I have all the prefs under tabbed browsing checked. If anything, it should be
opening a new tab. But by default, it should of course load in the current
window (whichever one launched bm manager). That's how NS4 did it.
Keywords: 4xp

Comment 3

16 years ago
marking p2 and mozilla0.9.8
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla0.9.8

Comment 4

16 years ago
Pushing out to mozilla1.1, probably need yet another pref to control this...
Target Milestone: mozilla0.9.8 → mozilla1.1
(Assignee)

Comment 5

16 years ago
->me
Assignee: pchen → blakeross
Status: ASSIGNED → NEW
(Assignee)

Comment 6

16 years ago
I checked in the fix for this yesterday.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

16 years ago
V. Open, open in new window, and double click all behave as expected.

Although, the method it uses to pick which window to load for 'Open' is a bit
odd.  If I open manager bookmarks, then open a link, it loads in window #1. If I
do new window, then 'Open' a bookmark. It loads in window #2. If I give focus
back to #1 though, bookmarks still load in #2. If I focus a new tab in #1
however, they load in window #1 tab #2.

I would imagine, however, it will pick an acceptable/expected browser 99% of the
time.

Comment 8

16 years ago
I can imagine changing it so that the DEFAULT is not to have double-click open a
link in a new window, but that's what I want.  I was delighted when I noticed
that Mozilla opened links in a new window by default, when I double-click at least.

Why can't the behavior of double-click on a link be a configuration item?  I
would be perfectly happy to have the default to not open a link in a new window,
but I would quickly change it so that it WILL open a link in a new window.
(Reporter)

Comment 9

16 years ago
Because left click on any other link defaults to the current window. File a bug
on middle click not opening a new window/tab as it should, if you want. But a
pref would be ridiculous, we're already sufering from pref bloat.

Comment 10

16 years ago
So, from what I've read (and guessed) on searching for "middle-click",
apparently a single middle-click on a bookmark is supposed to open the link in a
new window, if the preferences item in tabbed browsing labeled "Middle-click or
control click ..." is on.  However, that doesn't seem to work.  Is that your
point about filing a bug about it not working?  If that's the case, then I'll
file a bug.  Using single middle-click as opposed to double left-click is fine
with me.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.