CRASH: Routing Recipient causes MS Word to crash.

VERIFIED FIXED

Status

MailNews Core
Simple MAPI
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Trix Supremo, Assigned: Krishna Mohan)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
With Netscape Mail as the default, in MS Word if you select "Routing Recipient"
instead of "Mail Recipient(as Attachment)...", an application error will occur.

DIRECTIONS:
1. Set Netscape Mail to be your default email client.
2. Open MS Word(don't need to enter anything into the document)
3. Select File|Send To|Routing Recipient

ACTUAL RESULTS:
An application error occurs causing MS Word to crash.

EXPECTED RESULTS:
With Outlook Express as the default, the Routing Slip dialog is displayed.

With Communicator 4.x as the default, a "General mail failure.  Close Microsoft
Word, restart the mail system, and try again." which is an error dialog from MS
Word.

At least with 4.x, we exit gracefully.
(Reporter)

Comment 1

17 years ago
Just an additional note.  This is not isolated to just MS Word, but Excel
displays the same problem.  On Powerpoint though, it exits gracefully with an
error dialog "Powerpoint found an error and it can't correct...", exiting the
app does allow you to save the doc and exit.
(Assignee)

Comment 2

17 years ago
Created attachment 53669 [details] [diff] [review]
fix for the crash problem.
(Assignee)

Comment 3

17 years ago
The problem is with returning SUCCESS_SUCCESS instead of MAPI_E_FAILURE for
unsupported functionalities in this release.   There is no need to return
MAPI_E_FAILURE from the functions those do not have OUT parameter, still I feel
it is better to let the app. know about it.

Rajiv  - Can you please review
mscott - Can you please super review the same

Thanks
(Assignee)

Comment 4

17 years ago
Forgot to CC Rajiv (Reviewer)
(Assignee)

Comment 5

17 years ago
Created attachment 53678 [details] [diff] [review]
New patch with more context

Comment 6

17 years ago
good, this patch is easier to review.

r=rdayal.

Since this could help in removing probable crashes when calls are made to
non-implemented Simple MAPI functions by the mapi apps, am nominating this for 
094 branch. A simple no brainer kinda change/fix.

Comment 7

17 years ago
What does the user see with this patch for these unsupported items?
Keywords: crash, nsbranch

Comment 8

17 years ago
MAPI is a set of APIs which returns error codes, what the user sees is completly
based on what the MAPI apps displays to the user when they get these return codes. 

Comment 9

17 years ago
Comment on attachment 53678 [details] [diff] [review]
New patch with more context

sr=mscott. Not really much for me to review here. I'm assuming with these changes our 4 basic mapi clients still work....
Attachment #53678 - Flags: superreview+

Comment 10

17 years ago
pls get this in tonight = PDT+

Updated

17 years ago
Whiteboard: [PDT+]

Updated

17 years ago
Attachment #53678 - Flags: review+

Comment 11

17 years ago
This wasn't checked in last night?  

Updated

17 years ago
Keywords: nsbranch+, nsenterprise+

Comment 12

17 years ago
Will be checked in today.

Comment 13

17 years ago
hmmmm ... we didn't check this in last night?

Comment 14

17 years ago
Checked into 0.9.4 branch

Comment 15

17 years ago
Trix:

Please verify this bug on tomorrow's build ASAP. Many thanks.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

17 years ago
verified on 2001-10-17-05-0.9.4

General Mail Failure warning dialog is now displayed instead of crashing which
is the same behavior as Comm. 4.x.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.