[e10s] Divel Notepad crash Firefox when I click the View Notes button

RESOLVED DUPLICATE of bug 1048968

Status

()

Firefox
Extension Compatibility
RESOLVED DUPLICATE of bug 1048968
3 years ago
3 years ago

People

(Reporter: adrian.arroyocalle, Unassigned)

Tracking

({addon-compat, crash})

Trunk
addon-compat, crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

I acivated Electrolysis on Firefox Nightly 34 and I clicked the button to see notes. 


Actual results:

It crashed Firefox


Expected results:

It should have opened the panel. It was working without e10s
(Reporter)

Updated

3 years ago
Component: Untriaged → Extension Compatibility
Keywords: addon-compat
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 1

3 years ago
How do you open notes when e10s is enabled? I don't see the add-on icons in the toolbar.
(Reporter)

Comment 2

3 years ago
Yeah, it's true. I've checked now and the buttons doesn't appear but other addons using Addon SDK buttons still work.

Comment 3

3 years ago
So how can I test Divel Notepad in e10s mode?
(Reporter)

Comment 4

3 years ago
Well, it's still a bug
Adrian: do you have a crash report ID or link from Firefox's about:crashes page for this crash?
Blocks: 899758, 905436
tracking-e10s: --- → ?
Keywords: crash
(Reporter)

Comment 6

3 years ago
Of course: https://crash-stats.mozilla.com/report/index/0e198dbc-6f54-4040-9d15-002b82140808

Also mention that if you disable and re-enable the addon it shows the buttons on the toolbar
(Reporter)

Comment 7

3 years ago
This was from yesterday, exactly the same: https://crash-stats.mozilla.com/report/index/ee693a32-ba3a-4563-8d1e-05ac22140807

Comment 8

3 years ago
I crashed too: https://crash-stats.mozilla.com/report/index/f33c986f-6b2b-44a1-a153-5ae752140808

It's a dupe of bug 1048968.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1048968
(Reporter)

Comment 9

3 years ago
My mozillian profile: https://mozillians.org/es/u/adrian.arroyocalle/
No longer blocks: 899758, 905436
tracking-e10s: ? → ---
You need to log in before you can comment on or make changes to this bug.