[Messages][Build] Add build script to ignore the desktop-only folder for production build

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: azasypkin, Assigned: azasypkin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sms-sprint-2.1S6])

Attachments

(1 attachment)

*** Follow-up from bug 1044224 ***

See bug 1044224 comment 9 for details.
(Assignee)

Updated

4 years ago
Summary: [Messages][Build] Update build script to ignore the desktop-only folder for production build → [Messages][Build] Add build script to ignore the desktop-only folder for production build
(Assignee)

Comment 1

4 years ago
Seems that send button doesn't work in Firefox browser anymore + some mozSettings exceptions are thrown, will try to fix it in the scope of this bug too.
Assignee: nobody → azasypkin
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
Created attachment 8485612 [details] [review]
GitHub pull request URL

Hey Steve,

Here is one more low-priority review for you :)

Here I've added build.js that removes desktop-only folder + my attempt to remove all desktop-only "if/else" cases from code with the help of build script.

Thanks!
Attachment #8485612 - Flags: review?(schung)
Comment on attachment 8485612 [details] [review]
GitHub pull request URL

left some comments on github but I didn't do a full review so I leave the request for Steve.
(Assignee)

Comment 4

4 years ago
Comment on attachment 8485612 [details] [review]
GitHub pull request URL

Hey Julien,

Since Steve is on PTO this week, could you please review it in full then? :)

Thanks!
Attachment #8485612 - Flags: review?(schung) → review?(felash)
Comment on attachment 8485612 [details] [review]
GitHub pull request URL

Added some comments

globally looks good :)
Attachment #8485612 - Flags: review?(felash)
(Assignee)

Comment 6

4 years ago
Comment on attachment 8485612 [details] [review]
GitHub pull request URL

Hey Julien,

Comments addressed, except for the regex part - I think we'd rather leave it as simple as possible for now and rethink only if we need it...

Thanks!
Attachment #8485612 - Flags: review?(felash)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1073366
Comment on attachment 8485612 [details] [review]
GitHub pull request URL

r=me with some nits
thanks for this work, this is really useful !
Attachment #8485612 - Flags: review?(felash) → review+
(Assignee)

Comment 9

4 years ago
(In reply to Julien Wajsberg [:julienw] from comment #8)
> Comment on attachment 8485612 [details] [review]
> GitHub pull request URL
> 
> r=me with some nits
> thanks for this work, this is really useful !

Thanks for review! Nits fixed.

Master: https://github.com/mozilla-b2g/gaia/commit/5937b83558594d615f3dd78aeee6fde7da7a18a3
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [sms-sprint-2.1S6]
You need to log in before you can comment on or make changes to this bug.