Last Comment Bug 105045 - update date/time formatter on Mac OS X (CFDateFormatter)
: update date/time formatter on Mac OS X (CFDateFormatter)
Status: RESOLVED FIXED
: intl
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- enhancement (vote)
: Future
Assigned To: Nobody; OK to take it and work on it
:
: Makoto Kato [:m_kato]
Mentors:
http://developer.apple.com/documentat...
Depends on: 360018
Blocks: 103669 dateandtime
  Show dependency treegraph
 
Reported: 2001-10-16 06:51 PDT by Frank Tang
Modified: 2009-10-26 07:49 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Frank Tang 2001-10-16 06:51:35 PDT
Mac OS X have some new Unicode baes API.
Our current date time formatter in intl/locale are based the script system one from 
system 7. It did a lot of change of data since we need to convert from / to
unicode. It will be nice to develop a new implementaion of nsIDateTimeFormatter
if Mac OS X have a new library to handle it. 
So far I have not find any documentation mention such library exist. We should
talk to Apple's Technology Manager to get more info.

Please add info to this bug if you find out anything related to date and time
display on Mac (new apis)
Comment 1 Frank Tang 2001-10-16 13:03:24 PDT
I look at CFDateRef in Core Foundation : Utility Services. I cannot find any API
format a CFDateRef to a localized string.
Comment 2 Frank Tang 2001-10-16 15:18:46 PDT
mark it as m1.0 for now till more information collected. 
Comment 3 Frank Tang 2002-02-14 11:43:25 PST
this thing does not exist. push off to future. 
Comment 4 jhp (no longer active) 2004-08-27 09:17:40 PDT
The APIs that replace the current script system are CFDateFormatter and
CFNumberFormatter.  These are both only available starting in 10.3, so we'll
have to create a fix like that from bug 252475, where we dynamically load the
function pointers and if they exist (i.e. we are on 10.3 or later), then we use
these new APIs.  We'll need to keep the old code around for older systems.
Comment 5 Constantine A. Murenin 2006-12-25 08:26:06 PST
(In reply to comment #4)
> The APIs that replace the current script system are CFDateFormatter and
> CFNumberFormatter.  These are both only available starting in 10.3

When are we dropping support for 10.2 and older? 

Mozilla documentation on OS X support is not very clear on this ATM, for example, dmo says, «Mozilla will run on Mac OS X 10.2 (“Jaguar”), but the build requires a minimum of 10.3 (“Panther”).», whilst wmo says that 10.2 is supported for neither runtime nor building of Gecko 1.8 and 1.9 (trunk). Moreover, caminobrowser.org claims that Camino 1.0 supports 10.2, whilst wmo says that even Camino 0.8 doesn't support 10.2. IMHO, the Compatibility Matrix needs a really major update.

http://developer.mozilla.org/en/docs/Mac_OS_X_Build_Prerequisites
http://wiki.mozilla.org/Mac:Build_Requirements#Compatibility_Matrix
http://www.caminobrowser.org/
Comment 6 Constantine A. Murenin 2006-12-25 09:18:44 PST
(In reply to comment #5)
> (In reply to comment #4)
> > The APIs that replace the current script system are CFDateFormatter and
> > CFNumberFormatter.  These are both only available starting in 10.3
> 
> When are we dropping support for 10.2 and older? 
> http://wiki.mozilla.org/Mac:Build_Requirements#Compatibility_Matrix

H'm.. I guess, I misread the matrix this morning before tea :) — it looks like in trunk (Gecko 1.9) we already no longer support 10.2 and older, so we can already use CFDateFormatter without any fallbacks to older APIs.
Comment 7 Simon Montagu :smontagu 2009-10-26 07:49:08 PDT
Fixed by bug 360018

Note You need to log in before you can comment on or make changes to this bug.