Closed Bug 1050491 Opened 5 years ago Closed 5 years ago

crypto api should be available inside WebWorkers

Categories

(Core :: DOM: Workers, defect)

31 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 842818

People

(Reporter: patrick232, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2114.2 Safari/537.36

Steps to reproduce:

Browse this minimal demo: http://jsbin.com/fekumuxu/1


Actual results:

In the console i geht an Error:

ReferenceError: crypto is not defined blob:23071d41-50de-4a82-a107-a870e7c46a0a:1


Expected results:

There should not be any Errors, the crypto api should be available inside WebWorkers

Relevant issue in the browserify-ecosystem: https://github.com/dominictarr/crypto-browserify/issues/46

I attached the demo as html-file
Component: Untriaged → DOM: Workers
Product: Firefox → Core
Summary: crypto in WebWorkers → crypto api should be available inside WebWorkers
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 842818
You need to log in before you can comment on or make changes to this bug.