Moving element may leave traces with HWA off

VERIFIED FIXED in Firefox 35

Status

()

Core
Layout
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: obrufau, Assigned: mstange)

Tracking

({regression})

34 Branch
mozilla35
x86
Windows XP
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox35 verified)

Details

Attachments

(4 attachments, 3 obsolete attachments)

244 bytes, image/gif
Details
448 bytes, text/html
Details
11.77 KB, text/html
Details
3.96 KB, patch
roc
: review+
Details | Diff | Splinter Review
(Reporter)

Description

4 years ago
Created attachment 8469552 [details]
Screenshot

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140807030202

Steps to reproduce:

Open the attached demo, and let the element move.


Actual results:

At some points it will leave traces.


Expected results:

It shouldn't.
(Reporter)

Comment 1

4 years ago
Created attachment 8469554 [details]
Demo
(Reporter)

Comment 2

4 years ago
Created attachment 8469557 [details]
Screenshot 2
(Reporter)

Comment 3

4 years ago
Created attachment 8469559 [details]
Demo
Attachment #8469554 - Attachment is obsolete: true
Attachment #8469557 - Attachment is obsolete: true
(Reporter)

Comment 4

4 years ago
Created attachment 8469561 [details]
Demo
Attachment #8469559 - Attachment is obsolete: true
Can't reproduce, 34.0a1 (2014-08-07), Win 7 x64.
Please check if the issue occurs using Firefox in safe mode (with your addons disabled):
http://support.mozilla.com/kb/Safe+Mode

And on a new, empty profile:
http://support.mozilla.org/en-US/kb/Managing-profiles#w_starting-the-profile-manager
Component: General → Layout
Flags: needinfo?(obrufau)
(Reporter)

Comment 6

4 years ago
(In reply to Paul Silaghi, QA [:pauly] from comment #5)
> Can't reproduce, 34.0a1 (2014-08-07), Win 7 x64.
> Please check if the issue occurs using Firefox in safe mode (with your
> addons disabled):
> http://support.mozilla.com/kb/Safe+Mode
> 
> And on a new, empty profile:
> http://support.mozilla.org/en-US/kb/Managing-profiles#w_starting-the-profile-
> manager

Yes, I already tested it on a new profile.

Maybe it only happens on Win XP, or with with HWA off.
Flags: needinfo?(obrufau)
Thank you.
Confirmed with HWA off, 34.0a1 (2014-08-07), Win 7 x64.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Moving element may leave traces → Moving element may leave traces with HWA off
(Reporter)

Comment 8

4 years ago
Created attachment 8470990 [details]
Demo 2

This demo directly sets top and left properties from a given list of values, without jQuery.
(Reporter)

Comment 9

4 years ago
Good: 32.0a1 2014-05-13 (4b6d63b05a0a)
Bad: 32.0a1 2014-05-14 (2f8af55d6e9a)
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4b6d63b05a0a&tochange=2f8af55d6e9a

Latest versions:
 * 35.0a1 2014-09-22 - affected
 * 34.0a2 2014-09-22 - affected
 * 33.0b5 - unaffected
 * 32.0.2 - unaffected
Thanks obrufau!

Last good revision: 971b840c40ff
First bad revision: 35af5d1c97c3
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=971b840c40ff&tochange=35af5d1c97c3

Markus, it seems to be one of your patches.
Flags: needinfo?(mstange)
Keywords: regression
(Assignee)

Updated

4 years ago
Assignee: nobody → mstange
Blocks: 1008301
Status: NEW → ASSIGNED
Flags: needinfo?(mstange)
(Assignee)

Comment 11

4 years ago
Created attachment 8493890 [details] [diff] [review]
patch
Attachment #8493890 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/50eddcdf4cbb
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
(Reporter)

Comment 14

4 years ago
Comment on attachment 8493890 [details] [diff] [review]
patch

Review of attachment 8493890 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/reftests/bugs/1050493-1.html
@@ +36,5 @@
> +  }
> +}
> +window.addEventListener("MozReftestInvalidate", function () {
> +  f();
> +});

I think a wrapper function is not needed:
> window.addEventListener("MozReftestInvalidate", f);
(Assignee)

Comment 15

4 years ago
You're right, I noticed that after I checked it in, but since it's just test code it doesn't matter.
Verified fixed 35.0a1 (2014-09-25) Win 7
Status: RESOLVED → VERIFIED
status-firefox35: --- → verified
You need to log in before you can comment on or make changes to this bug.